Hello Guest it is February 19, 2020, 12:43:41 AM

Author Topic: PcI Parallel port not recognized but mach 3 driver installer  (Read 2553 times)

0 Members and 1 Guest are viewing this topic.

PcI Parallel port not recognized but mach 3 driver installer
« on: September 09, 2014, 11:30:55 AM »
I am using a new computer with windows 7 64bit  had to install a PCI parallel card which loads up in the windows driver giving me an address of E100 - E103. The port tester verifies the E stop port changes state if button is pressed then reset, but runing in mach 3 refuses to acknowledge the card or address. I have tried e100 i both port boxes to correlate with LPT2 or 1 which ever the driver is set to.

Can some one please advise how do I get mack to recognize address/ card.
Checked bios the pci card indicates it is used
Struggling to figure this out.
CNC works on old pc with mother board based parallel  port but it has issues hence the new PC

Wisdom please

Offline ger21

*
  • *
  •  6,279 6,279
    • View Profile
    • The CNC Woodworker
Re: PcI Parallel port not recognized but mach 3 driver installer
« Reply #1 on: September 09, 2014, 11:47:53 AM »
You can't use the parallel port with Mach3 in a 64 bit OS.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: PcI Parallel port not recognized but mach 3 driver installer
« Reply #2 on: September 15, 2014, 09:01:32 AM »
Thanks Have gone back to Old PC, Shame
However this in now my issue
When I first set up system the Hot keys work XYZ now that I have loaded a file or 2 and tried to position or move spindle up and down to change tools etc none of the hot keys work now, can anyone shed some idea what I may have change inadvertently even on start up now I have no control

please advise

Offline ger21

*
  • *
  •  6,279 6,279
    • View Profile
    • The CNC Woodworker
Re: PcI Parallel port not recognized but mach 3 driver installer
« Reply #3 on: September 15, 2014, 11:16:10 AM »
Make sure your in continuous jog mode, and not MGP mode.
Also, you can only jog on screens with a jog on/off button.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: PcI Parallel port not recognized but mach 3 driver installer
« Reply #4 on: September 16, 2014, 06:03:25 AM »
thanks for some reason the jog buttons would not change state but now have control. shut down and reset I think also fixed it