Hello Guest it is October 14, 2019, 03:07:38 PM

Author Topic: Mach3 Camera Plugin V3  (Read 16840 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach3 Camera Plugin V3
« Reply #10 on: October 24, 2015, 06:20:10 AM »
Hi Klaus

I have deinstalled the plugin and downloaded and reinstalled  V3.02 again.  It produced the same result of "Plugin dll defective". 

It may not be relevant, but I noticed that about halfway through the installation, I always get asked to repair Microsoft Visual C++2010 x86.  I followed the instructions to repair this, including a reboot, and I got the message that it had been successfully repaired.  However, when starting Mach3, I get the dll defective messages again.

Regards

David
Re: Mach3 Camera Plugin V3
« Reply #11 on: October 24, 2015, 11:28:58 AM »
Hi David,

What main processor type are you using, is it perhaps an AMD? Please install the attached PluginTest, run it and use menu Test -> Analyze. This will put some files on your C - drive. If you send me these files I will have a look at it.

Regards
Klaus
The brain isn't a soap, it doesn't shrink when used.
Re: Mach3 Camera Plugin V3
« Reply #12 on: October 25, 2015, 06:52:36 AM »
Thanks for the quick reply.

I installed your Plugin Test and ran Test -> Analyze.  I got a message box headed "Plugin Test Error" with the message "Plugin not installed or not at least started once".  Hit OK, and got a table describing various features of my installation.  I got 7 files on the C drive, which are attached.

The CPU is an AMD Athlon(tm) XP 2600+

Thanks

Regards
Re: Mach3 Camera Plugin V3
« Reply #13 on: October 25, 2015, 08:02:10 AM »
Hi David,

I think I have bad news. Plugin version3 is completly rewritten. With that version I'm using the OpenCV library. This library obviously has problems with AMD Athlon processors. For the moment I don't have a solution for this problem. Depending on the feature you need, you could use version2 where I'm using a different library. You'll find it attached to this post.

Regards
Klaus
The brain isn't a soap, it doesn't shrink when used.
Re: Mach3 Camera Plugin V3
« Reply #14 on: October 25, 2015, 12:41:03 PM »
Hi Klaus

I tried V2 and it works correctly on the AMD machine.  I installed V3 on another machine with an Intel processor and V3 worked correctly, so it seems that the AMD Athlon is the culprit.

Thank you very much for your help.

Regards

David