Hello Guest it is August 04, 2021, 12:28:51 PM

Author Topic: Weird action in Mach 3 - need help  (Read 2595 times)

0 Members and 1 Guest are viewing this topic.

Weird action in Mach 3 - need help
« on: September 01, 2014, 12:55:09 PM »
Over the past several months I have been using my cnc router in a weird manner, by connecting it to a mini wood lathe to create a cnc lathe setup.  The lathe holds and spins the wood while the router, using a fixed carbide insert, does the profiling.  This has been working very well for me, but the setup that I use does not require the use of the Z axis, apart from setting the tool height on the lathe.  After that has been done, I go into the Mach setups and disable the Z axis so that I don’t accidently move it up or down.  

All this is good, however today I had to do some regular 3D routing to create a mold for a friend, so for the first time in many months the Z axis now comes into play.  This is a 14 hour process between roughing and finishing passes.  So today the first 7 hour stint was for the roughing pass.  In my process of getting things setup and switched around I had to move the Z axis up and down many times and I found that in doing so it acted very strange.

When I pressed and held the manual jog key, the Z would start to move in a normal acceleration mode for about a second or so until it reached what I think was the max speed, then it would slow down (decelerate) over a few seconds, then it would accelerate again back up to the max speed and maintain that speed as long as the key was held down.  This would happen in both directions every time I pressed the up and down keys.  When the Z axis was moving fast and slow and fast again, you could see the numbers in the DRO reflect that fast/slow motion every time, so it appears as though Mach was generating some weird signal that is causing the stepper motor to work like this.  At no time did it sound as though the motor was skipping steps so I tried running the file hoping that things would turn out ok, but they didn’t.

Running the router, constantly over the course of about 6-1/2 hours, the DRO screen on Mach said that the cutter should be at -1.7500” but in fact the cutter was actually at about -.6600”.  So for some reason the Z axis has lost over 1” of depth.  I don’t know if it would be possible that Mach would change the scaling on just the Z axis to do that or not?  At least the work piece is salvageable since the cutting was just less than it was supposed to be, so once I get things working properly I can start over.  If this was attributed to missing steps, then one would think that it would be out a lot more than that, over that period as the router should miss steps in the up direction more so than when going down, due to the weight of the axis mechanism.  The Z axis runs on a ball screw so it is pretty free to turn – at least it is supposed to be.

Before I actually ran the file, I did a calibration check (just once though) on the Z axis and it moved 1” for me and was within less than 0.001” so I didn’t check that any further.

One thing that I have so far is to remove the suspect motor and test it out without being connected.  I first determined that the ball screw on this axis is still free to turn, so the bearings etc seem to be out of the equation.  Next I booted up the controller and with the motor lightly clamped down I proceeded to do some rapid joggles with the motor.  With the motor sitting free I could still get the same acceleration, de-acceleration and re-acceleration as when it was installed.  The motor will accelerate for about 2 seconds, then slow down almost to a stop, then pick back up a and accelerate up to full rapid speed.  What now get stranger is that repeated tests - going in the same direction very rarely repeat the weird acceleration action, the motor seems to operate normally by accelerating then holding a constant speed.  Where the weird action shows up is when I reverse directions.  I appears as though the de-acceleration process only shows up on the first motion of the motor, as repeated tests in any one direction allow the motor to operate normally - until you reverse it.

Naturally this is where the cnc routing will be affected since the motor action is almost a reversing process every time it moves, so with this weird thing happening the cnc router is off the grid until I can solve the problem.

The X and Y axis, do not act in this manner they are working just fine.  The X axis is a dual drive with 2 – 1260 stepper motors (slaved to the A axis) and connected with timing belts geared 4:1.  The Y axis is a 1:1 ball screw with a 960 stepper on it.  The stepper on the Z is a Nema 23 1:1 575 oz in motor.

The controller I am using is a 4 axis unit from Xylotex with Gecko 202 drivers.

I have never seen Mach do this before and I am hoping someone might have an idea or maybe someone has seen this happen previously.  I have attached a copy of my .xml file if that might help.


Peter Stenabaugh
Re: Weird action in Mach 3 - need help
« Reply #1 on: September 01, 2014, 06:39:27 PM »
Ok, here is an update to the eratic Z operation..... problem solved with thanks to Art.

The initial problem was solved by using a new .xml file.  Recently I had run the same file on my cnc milling machine (14 hour run - flawlessly), so I copied that xml file to my router.  I did an initial test just as the file came in without changing anything and low and behold the eratic operation vanished.  Now I was both happy and confused and I wanted to know why this happened for future reference.  I continued along and gradually reset all my motor parameter and configurations, testing as I went to ensure nothing weird would pop up.

It was all good now however in this process I also realized that the Z axis had never been calibrated since I had installed my Xylotex controller - because I didnt need the Z for the lathe operation, except to set the cutter height, but I had forgotten all about that.  With the Z axis calibrated, now I was ready to go.  That resolved my dilemma as to why after 7 hours of cutting the cutter had only penetrated -.650" whereas the Mach DRO was showing -1.75".

With things all solved I re-started the 14 hour routing process, and now about 3 hours in, everything is running fine.

Art sent me an email saying that he figured the issue was because of backlash.  I replied saying I had no backlash due to my design of using ball screws and timing belts. Art replied back that the issue was likely due to 'BACKLASH' being enabled in Mach.  So now I had to check that out.....

I loaded up Mach3 alternately using each of the xml files.  First off the old suspect one, and low and behold the damn backlash WAS enabled, it was set to 20% and the Z axis was also selected with a backlash of 0.0035"...... wow, I have no idea where that came from, but there it was........ when I booted up with the newly configured file I found that backlash was NOT enabled, although it was set to 100% which I think is the default.

So this certainly seems to be the root of the problem.  Once I am finished my routing project I will play with this backlash setting and see if I can replicate the eratic operation.  I am pretty sure this is the answer but I just want to know for sure, for future reference.

So for you other guys out there, keep this in mind if your machinery starts doing weird things on you.....