Hello Guest it is February 26, 2021, 05:47:13 AM

Author Topic: Slave and master running different steps / speeds  (Read 1761 times)

0 Members and 1 Guest are viewing this topic.

Slave and master running different steps / speeds
« on: July 27, 2014, 02:09:28 PM »
Hi all

I have been a silent member for years, but now I suddenly got a problem that has stumped me.

I run a plasma system with Gecko drives where my X-axis is slaved (B). This system has run faultlessly for over two years now and suddenly two days ago after the machine was switched on, the slave axis now runs about 50mm further over 2m than the master X.

When I return them to zero (G0 x0) they both return to exactly zero, repeatedly from any position on the table. It just seems that the slave and master no longer run in synch.

On my motor tuning screen the steps, acceleration, etc. are identical for X & B, the right boxes are clicked in the master / slave screen and basically nothing has been changed over the past few years.

Something that may or may not be related, is that on the "Diagnostics" screen (right hand bottom) the "output 6" LED is constantly flashing, even if the drives are all switched off. This has been the case for as long as I can remember (2 years +) but what does intrigue me is that the misbehaving slave motor's step pin is also number 6 on port 1. Could this be related?

Any help would be appreciated!

Regards
Neil

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Slave and master running different steps / speeds
« Reply #1 on: August 01, 2014, 06:34:40 PM »
Cant think of anything but can have a look through your xml if you attach it, might see something there.
Hood
Re: Slave and master running different steps / speeds
« Reply #2 on: August 05, 2014, 05:33:59 AM »
Hi All

After having dissembled nearly my whole machine, I found that the pinion on the master drive had a loose grub screw that caused the inaccuracy in the first place. It took days to find, but believe me - next time it will be the first place I look!
 
Re: Slave and master running different steps / speeds
« Reply #3 on: August 05, 2014, 06:34:35 AM »
Thanks for posting your solution. Others will likely benefit from your experiences.
Good job !

Russ  :)
« Last Edit: August 05, 2014, 08:08:03 AM by Overloaded »