Hello Guest it is June 24, 2019, 04:24:37 PM

Author Topic: Win7 - ESS - XML config  (Read 1411 times)

0 Members and 1 Guest are viewing this topic.

Win7 - ESS - XML config
« on: July 15, 2014, 08:51:10 AM »
Hello,
Does anybody know how to solve an issue with xml configuration file. I will try to explain what is happening. With WinXP, the XML file is always dated to the date od last config change. And of course it contains ALL config data. With Win7, the weird things are happening. The setup is ok, the machines are working as they should, but the XML files are outdated and does not contain data. How to make backup and where to find correct XML file??
Thanks in advance,

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Win7 - ESS - XML config
« Reply #1 on: July 15, 2014, 11:33:55 AM »
If the XML did not contain data then your machine would not work as there would be no settings for Mach to read in.

I suspect what your seeing is that the 'C:\', i.e. root, is protected and Mach3 does not have full permissions. I have seen this happen with Enterprise versions of Win7, you have to run Mach 3 as administrator and/or have the permissions changed for C:\mach3 to give the users running Mach 3.
Happy machining , Jeff Birt
 
Re: Win7 - ESS - XML config
« Reply #2 on: July 16, 2014, 03:57:55 AM »
Jeff,
Thanks for supporting.
As I told, the weirdest thing is that machine is configured well and works as it should. BUT in Mach folder there is no such XML file. For example, there is Mach3Mill.xml from 28-6-2010 which is totally different than machine working setup. Actually, if I make a change and reboot, there will not be any file containing today date in Mach root folder, but machine will work as it should. Like it stores changes somewhere out of Mach folder.

I am totally confused.

BR