Hello Guest it is December 05, 2021, 03:30:35 AM

Author Topic: 4 Axis foam cutter problems with set up  (Read 1273 times)

0 Members and 1 Guest are viewing this topic.

4 Axis foam cutter problems with set up
« on: July 01, 2014, 06:51:01 AM »
Grettings all,

I'm a newbie at this and I have quite a few problems setting it all up.

Little background information, machine was bought from a person who made it himself or so he says. Electronics looks like it was made by him (judging by names and marks on circuit) so I don't really know which pin goes where on printer port.

So first thing, foamworks works normally, I can move single axis are both X / Y or all.
So normally I tried copying pins into mach 3 and I couldnt move anything, I was trying to figure out output pins and enable.
From foamworks I know this:
X1 direction pin 2
X1 step pin 3
X2 direction pin 6
X2 step pin 7

y1 direction pin 4
y1 step pin 5
y2 direction pin 8
y2 step pin 9

I setted enable and output pins same as step pin and was only working on getting X axis to move.

I got it to move X (but it's not working anymore) so I could move X and X2 (slave A). But it could only move once. Meaning if I pressed tab in mach and move axis X (button jog) it would move and it would keep moving until button was pressed.

Then if I try to move it again (again button press) it won't move until I open Parallel Port Monitor and click on pins so everything is green (low?) except pins 10-13, 15 which cannot be changed (input pins?).
So question here is how can I set it up so mach will return the pins to previous state?

After that I tried to move Y axis same as X even though I knew it could only be moved once. But as soon as I enabled Y and Y2 (slave B)
I couldnt move anything, not X or Y, so I disabled Y again and I still couldnt move X although it was same as before.

So now after pulling my hair out and googling for good 4 days I ran out of ideas.

Now only thing that works is this:
I click on jog button to move anything, motor spins for 1 second and stops. Wont move anything again until I click on pins on Port Monitor.

steps for motor is 157, kernel speed is 25k, computer running XP SP2, 1Gb ram 3,4Ghz CPU

I would appreciate all the help I can get.