Hello Guest it is April 19, 2019, 08:54:51 AM

Author Topic: beginner- can't get motors to turn, they do go to a hold.  (Read 1649 times)

0 Members and 1 Guest are viewing this topic.

beginner- can't get motors to turn, they do go to a hold.
« on: April 25, 2014, 06:35:18 PM »
just got my machine ready to test but can't get any of the motors to move they seem to go to a hold steady.  It's acting like it may still be in a demo mode. when I bought my license and got the download I opened the file in mach3 but it never asked for any purchase verifacation but I did see it knows my name now, how can you tell real working mach3 from demo?   thanks Keith

Offline ger21

*
  • *
  •  6,200 6,200
    • View Profile
    • The CNC Woodworker
Re: beginner- can't get motors to turn, they do go to a hold.
« Reply #1 on: April 25, 2014, 06:49:28 PM »
The demo is a real working Mach3. If your name is displayed, then the license is active.
If the motors lock up, then the drives are working correctly.
If the motors don't move, then you possibly have an incorrect port address, or incorrect port and pin settings.

Could also be an issue with the PC, or the parallel cable.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: beginner- can't get motors to turn, they do go to a hold.
« Reply #2 on: April 25, 2014, 09:02:51 PM »
I just notice it says "mach3 demo" at the very very top of the page. then I clicked on the help tab and it came up on a license window but I could not enter anything into it and it also says demo. I emailing mach support for help.    thanks keith

Offline ger21

*
  • *
  •  6,200 6,200
    • View Profile
    • The CNC Woodworker
Re: beginner- can't get motors to turn, they do go to a hold.
« Reply #3 on: April 25, 2014, 09:04:03 PM »
The motors should still move in demo mode.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: beginner- can't get motors to turn, they do go to a hold.
« Reply #4 on: April 26, 2014, 01:51:55 AM »
Yeppi!!!!   it was still in demo mode but got the license downloaded in so that's all good. But that was not the only trouble there was in "motor outputs" the Dir low active & Step low active WERE not checked as per mach3 set-up video. now the motors run great and I can finish the set-up. thanks Keith