Hello Guest it is December 10, 2019, 03:50:33 AM

Author Topic: IP-a inputs all active after machine powered up  (Read 1544 times)

0 Members and 1 Guest are viewing this topic.

IP-a inputs all active after machine powered up
« on: April 29, 2014, 05:07:10 PM »
Hi there. Have any one come accros this problem. When I power up the machine after a few hours being shut down, all the inputs are active; all home and limits, e-stop, etc. The only way I can clear this is to run the firmware setup again and restart Mach. I have reinstalled another version of mach as well as firmware. I did not copy the xml thinking it might be corrupt. All still the same. The inputs are just active in Mach diagnostics not the plugin window. When plugin window is opened, normal inputs active like pressure switch, air ram sensors etc. If you try and clear the inputs by deactivating them in ports and pins without running the firmware all hell brakes loose, all axis' takes off at max rapid and spindle spits the tool out. Only way to clear safely is to run the firmware each power up which is a PITA. Any suggestions? I have tried different installations recommended by cs-lab, no luck

Offline Hood

  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: IP-a inputs all active after machine powered up
« Reply #1 on: April 30, 2014, 03:49:34 AM »
Not had any issues like that at all, if you attach your xml I can take a look and see if I can find an issue.