Hello Guest it is May 29, 2023, 08:34:03 AM

Author Topic: Problems with threading R3.042.040?  (Read 2337 times)

0 Members and 1 Guest are viewing this topic.

Problems with threading R3.042.040?
« on: March 12, 2014, 04:12:10 PM »
Hi All,

First post here after plenty of searching on the forum.

I have a Denford Orac Lathe running mach3, which I have purchased a licensed copy for.

Up until recently I haven't done any threading, but once I have tried, I am running into a few problems.

The Z axis will move nice and smoothly for most of the passes, then odd ones it jumps and loses its "timing", creating either a double thread or ruining the thread completely.

I have read that some versions of Mach have issues with threading, and I'm pretty sure my steppers are not missing steps, as auto turning operations run problem free.

Are there any known issues with R3.042.040 with threading?

Any help would be much appreciated.


Offline Hood

  •  25,835 25,835
  • Carnoustie, Scotland
    • View Profile
Re: Problems with threading R3.042.040?
« Reply #1 on: March 13, 2014, 04:02:05 AM »
Do tests cutting air or doing very fine passes and see how it behaves. Most problems come from either a poor index pulse or a spindle that can not maintain close to the commanded speed when cutting forces are applied. Also a VFD ithat tries to maintain spindle speed can cause issues as it tries to maintain speed and Mach tries to compute from slowdowns and the two fight each other.

If you attach your xml I can have a look through it to see if there are issues.

Offline RICH

  • *
  •  7,428 7,428
    • View Profile
Re: Problems with threading R3.042.040?
« Reply #2 on: March 13, 2014, 08:16:32 AM »
For threading the user should use a version 3.042.034 and above. Don't recall if there are problems with versions past .034
other than the latest version of Mach.

Re: Problems with threading R3.042.040?
« Reply #3 on: March 13, 2014, 12:44:03 PM »
Hi all,
I found the problem, I think I had created it myself.
I clocked the axis with a DTI and found that the movements were out by about 2 percent, so I had adjusted the steps per to account for it.
I found after discussing it with someone more in the know than me that it was being caused by the bearing preload being incorrect.
I removed the stepper and pulley, and reset the preload, taking up the slack.
I have reset the steps per to 200, and tried again.
Accuracy on that axis is now restored, and the threading program now works as it should.
Happy days.

Thanks for the quick responses.