Hello Guest it is March 01, 2021, 02:30:43 PM

Author Topic: Mach3 with Zenbot - Scaling Issue  (Read 1711 times)

0 Members and 1 Guest are viewing this topic.

Mach3 with Zenbot - Scaling Issue
« on: March 09, 2014, 11:20:25 PM »
Hi,

My name is Jim and I am trying to use Mach3 with my Zenbot CNC machine.  I am encountering some issues, however.

I have creating a toolpath for my drawing in Vectric 2D and now want to use Mach3 to control my machine.  The guy from Zenbot gave me a pre-set profile for Mach3 that is made to work with this particular machine.  Also note that I am using a MachforWin64 kit and Windows 8.

My issue is that when I load the G-Cod on Mach3 and jog the machine, Mach3 shows that I have moved a certain distance, like 2mm, but the machine has actually moved way more than that (like a foot!)  Does anyone know what my problem is?

Thanks in advance,

Jim

Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Re: Mach3 with Zenbot - Scaling Issue
« Reply #1 on: March 11, 2014, 06:59:00 AM »
To use Mach3 with a 64bit OS an external motion controller, like a Smoothstepper, etc. must be used.
Are you are using one?

Also make sure that the your units are consistant for both Mach configuraton and Vetric and scale is set at 1.

RICH
Re: Mach3 with Zenbot - Scaling Issue
« Reply #2 on: March 11, 2014, 09:50:19 AM »
Hi Rich,

Thanks for your help.  I figured out the issue.  I just had to reload the configuration sent to me by the CNC manufacturer.  Yes, I am using a MachforWin64 external motion controller.  Not really sure what was up with that but the problem seems to be fixed.

Thanks for your help,

Jim