Hello Guest it is December 02, 2021, 03:52:47 AM

Author Topic: Sherline 4 Axis Mill (For Laser Welding)  (Read 9455 times)

0 Members and 1 Guest are viewing this topic.

Re: Sherline 4 Axis Mill (For Laser Welding)
« Reply #20 on: October 18, 2013, 09:54:28 AM »
I got another (hopefully easy) question.

I'm using a PMDX-126 so I can have external cycle start, feed hold, and rewind functions. Those are working fine, the OEMs thread was very clear on how to accomplish this.

Now I am trying to control both the PMDX and the sherline board with the computer. I have two parallel ports on this PC, so I thought this would be simple. I plugged the PMDX into port 2 and the sherline board into port 1. This was because I had originally set up my motors on port 1. I moved all of the OEM triggers to port 2, but Mach keeps asking for an external E-stop. I tried setting the port for the E-stop to port 2, since the PMDX has a dedicated spot for E-stops, but after pressing apply, and exiting out of the ports and pins tab, the program returns this, "Your reset command is failing due to an external influence...etc"

When i return to ports and pins the E-stop was reset to be at port 1. Is this just where the program wants the E-stop to be connected? That is fine, but in that case, how do I reconfigure my motor outputs so that mach knows to communicate with port 2?

Offline Fastest1

  •  920 920
  • Houston, TX
    • View Profile
Re: Sherline 4 Axis Mill (For Laser Welding)
« Reply #21 on: October 25, 2013, 01:09:59 PM »
What does it say on the diagnostics page? Active state of E Stop possibly?
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)
Re: Sherline 4 Axis Mill (For Laser Welding)
« Reply #22 on: October 25, 2013, 02:49:35 PM »
I would love to answer that question, but unfortunately, I blew out my PMDX board. There was a water leak on the floor from another machine in the room...

I tried turning the E-stop to active low in the ports and pins tab to no avail.
Re: Sherline 4 Axis Mill (For Laser Welding)
« Reply #23 on: February 25, 2014, 02:58:51 PM »
So I've got some time to work on this again (finally) and I'm still pretty much at the same point as before.

I can only get one of the boards to work at a time.

If I make the motor control board communicate with port 1, they turn perfectly fine, but the breakout board for OEM triggers does not.

If i make the breakout board communicate with port 1, it works fine, but the motors do not move at all.

That makes me think that my second parallel port is not functioning correctly. But I'm not entirely sure how to fix it. The hex address is correct as far as I can tell.

Any ideas would be very appreciated.