Hello Guest it is February 17, 2020, 01:26:31 PM

Author Topic: Mach3 Going Crazy On Small Part  (Read 3263 times)

0 Members and 1 Guest are viewing this topic.

Mach3 Going Crazy On Small Part
« on: February 17, 2014, 03:42:40 PM »
Hi guys, although not a total newbie with mach3, my knowledge is quite limited, and I have a problem I just can`t figure out.
I am trying to machine out a small (keyring size) set of knuckle dusters for a friend (he`s a streetfighter motorbike rider) and every time I load in the .nc file from cambam, all I get is lots of circles, with the actual toolpaths just visible in all the lines.
I am drawing the part in solidworks, then using cambam to generate the g code, and then importing to mach3.
I have in the past made lots of basic shaped parts, which all came out fine, but this is the smallest part I have done with so many cut-outs, and irregular shapes, can anyone suggest anything, it`s driving me crazy!
I might also just add that the cutter actually follows all the paths of the circles.

In these photos, you can just make out the parts that are "meant" to be cut out. I am using a 3mm cutter for these, so as to avoid overlapping paths.



Offline Sam

*
  • *
  •  987 987
    • View Profile
    • hillbillyhilton.com
Re: Mach3 Going Crazy On Small Part
« Reply #1 on: February 17, 2014, 06:15:21 PM »
Most likely the "I-J" mode is set incorrectly. It is located in the menu CONFIG>GENERAL CONFIG. I would recommend setting it in the code itself, and not the menu, with G90.1 or G91.1
If this does not fix your issue, attach the code in a reply and we will have a look.
"CONFIDENCE: it's the feeling you experience before you fully understand the situation."
Re: Mach3 Going Crazy On Small Part
« Reply #2 on: February 17, 2014, 06:57:58 PM »
Thanks Sam, this may be a bit beyond me, but I`ll certainly take a look tomorrow and report back
Re: Mach3 Going Crazy On Small Part
« Reply #3 on: February 18, 2014, 07:24:21 AM »
Most likely the "I-J" mode is set incorrectly. It is located in the menu CONFIG>GENERAL CONFIG. I would recommend setting it in the code itself, and not the menu, with G90.1 or G91.1
If this does not fix your issue, attach the code in a reply and we will have a look.
You Sam, are a star  8)  I done as you suggested and immediately, when I loaded the .nc file, all the circles were gone. I then clicked "start cycle" and it went on to do the whole job perfectly. God only knows how long it would have taken me to figure that out myself, so all I can say is --   many thanks my friend :)

This is what I was cutting.

Offline Sam

*
  • *
  •  987 987
    • View Profile
    • hillbillyhilton.com
Re: Mach3 Going Crazy On Small Part
« Reply #4 on: February 18, 2014, 10:23:53 AM »
cool keyring! Thanks for sharing the end product with us. We feed on pics.
"CONFIDENCE: it's the feeling you experience before you fully understand the situation."