Hello Guest it is May 23, 2019, 07:37:33 PM

Author Topic: Homing and Home Offset  (Read 16989 times)

0 Members and 1 Guest are viewing this topic.

Re: Homing and Home Offset
« Reply #10 on: February 08, 2014, 06:09:34 PM »
Sorry for the delay in responding, I really appreciate the expertise and guidance you guys share it certainly sheds a lot of light on the numerous questions from us beginners.

I got a chance to get back in the shop this morning and was trying a few things with "SoftLimits" and the like and I have some additional setup/implementation questions.

Like I said earlier Homing seems to be working fine with the exception of my slaved axis "A" not individually homing even though it is on a separate pin and set to home in the Ports & Pins, not sure I understand what's going on there? I may start another thread if I can't get it figured out..

So, back to "SoftLimits", when I home the Machine using the "Machine Coord's" it zero's as it should ("Machine Coord's" turned on). I have the "Soft Limits" enabled ("Machine Coord's" turned off) as well, I then move my X, Y and Z axis to be in a location that I deem to be a starting point for cutting (Work Offset) and then try to Zero but Mach seems to not let me unless I hit the "Reset"?

Am I misunderstanding how this works? Shouldn't I be able to set the Work Offset by zeroing the axis, even though the "SoftLimits" are enabled?

My understanding is that "SoftLimits" are on or off and independent of the "Work Offset"?

Adam,







Offline ger21

*
  • *
  •  6,233 6,233
    • View Profile
    • The CNC Woodworker
Re: Homing and Home Offset
« Reply #11 on: February 08, 2014, 06:21:25 PM »
Like I said earlier Homing seems to be working fine with the exception of my slaved axis "A" not individually homing even though it is on a separate pin and set to home in the Ports & Pins, not sure I understand what's going on there? I may start another thread if I can't get it figured out..


In General Config, make sure that "Home Slave with Master" is NOT checked.

Quote
So, back to "SoftLimits", when I home the Machine using the "Machine Coord's" it zero's as it should ("Machine Coord's" turned on). I have the "Soft Limits" enabled ("Machine Coord's" turned off) as well, I then move my X, Y and Z axis to be in a location that I deem to be a starting point for cutting (Work Offset) and then try to Zero but Mach seems to not let me unless I hit the "Reset"?

1), you don't have to "turn on" machine coordinates when homing. The Machine Coordinates" button doesn't really turn them on/off, it just toggles which coordinates are displayed in the DRO's.

So, you're saying if you home the machine, and then jog somewhere, you can't zero any axis? Are you clicking the Zero buttons?
You may need to give a more detailed step by step explanation of EXACTLY what you're doing.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Hood

*
  •  25,815 25,815
  • Carnoustie, Scotland
    • View Profile
Re: Homing and Home Offset
« Reply #12 on: February 08, 2014, 06:37:05 PM »
If you are viewing Machine Coords when you press the Zero it will Zero, just you will not notice as you are not viewing Work Coords.
Hood
Re: Homing and Home Offset
« Reply #13 on: February 09, 2014, 06:03:45 PM »

In General Config, make sure that "Home Slave with Master" is NOT checked.

1), you don't have to "turn on" machine coordinates when homing. The Machine Coordinates" button doesn't really turn them on/off, it just toggles which coordinates are displayed in the DRO's.

So, you're saying if you home the machine, and then jog somewhere, you can't zero any axis? Are you clicking the Zero buttons?
You may need to give a more detailed step by step explanation of EXACTLY what you're doing.

Spot on Ger21 many thanks for that, got the Axis homing correctly now.

As for zeroing the DRO that also seems to be working now.. strange my mouse clicks seem to be delayed somehow.. gonna check in on a PC problem.

Thanks again.

Adam,