Hello Guest it is October 19, 2019, 03:59:24 AM

Author Topic: Tool change but no height change  (Read 2599 times)

0 Members and 1 Guest are viewing this topic.

Offline PatM

*
  •  19 19
    • View Profile
Tool change but no height change
« on: March 07, 2007, 02:22:03 PM »
I'm a newb so I don't really know where this problem originates. I was using the Vcarve demo before and had all the tool heights in the mach3 tooltable. When a tool change was called for it automatically adjusted the Z DRO to match the new tool.

Well, of course I uninstalled vcarve (good, just can't afford it yet) and I'm using VM5 now. I also updated mach3 to 2.0.053 at the same time. Now when I get a tool change it waits for me to swap out and hit cycle start etc, but it doesn't actually do anything to the Z DRO. So when I change from my 2 inch long 1/2" bit to the .375 inch long 1/8" bit the .375 ends up cutting air far above the work. I did find that if I hit pause right after the tool change then click the tool number and hit enter, the DRO is changed and everything works as expected. So it seems mach knows what tool number to use, but doesn't pay any attention to the height offset.

Now, I know its more than likely that its something about the VM5 post instead of Mach but I'm clueless as to what to look for.

Here's the start of a file with the tool change

G00 G49 G40.1 G17 G80 G50 G90
G20
(Engraving)
T3 M6
M03 S10000
G00 Z0.0625

Anything important missing there?

Hood

*
Re: Tool change but no height change
« Reply #1 on: March 07, 2007, 04:12:15 PM »
maybe try editing with M6 T3 instead of the other way?

Offline PatM

*
  •  19 19
    • View Profile
Re: Tool change but no height change
« Reply #2 on: March 07, 2007, 05:23:13 PM »
Actually, thats what the post originally put out. I tried swapping them manually as well, but no difference.

Hood

*
Re: Tool change but no height change
« Reply #3 on: March 07, 2007, 05:29:38 PM »
Have a look at the General Config page and see if there are any settings there that have been changed, not sure what ones to look for as I dont use tool offsets on the mill.
Hood

Offline PatM

*
  •  19 19
    • View Profile
Re: Tool change but no height change
« Reply #4 on: March 07, 2007, 06:34:07 PM »
Well duh. I dunno how I missed it when I was looking up the gcodes but, G49 is cancel length offset. Time to head out to the shed and try again!

Offline PatM

*
  •  19 19
    • View Profile
Re: Tool change but no height change
« Reply #5 on: March 07, 2007, 07:08:36 PM »
Well, that didn't work either. I read up some on G43/49 and figured out the rest of it. VM's mach 3 post file didn't add the G43[tool register #] to the gcode so it had no command to set the length offset. I muddled through it and now it seems to be working properly.

I had a feeling it wouldn't be a problem with Mach!