Hello Guest it is May 08, 2021, 02:24:58 PM

Author Topic: My X home switch is not backing off after homing this axis.  (Read 3968 times)

0 Members and 1 Guest are viewing this topic.

My X home switch is not backing off after homing this axis.
« on: January 21, 2014, 10:45:39 AM »
The Y axis still homes and backs off, but the X axis only homes, does not back off the switch any more.

What might cause this. Note, I have not made any changes, this just started happening.

XML posted in this thread (forum prevents posting same twice) http://www.machsupport.com/forum/index.php/topic,26374.new.html#new

Thanks!

Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: My X home switch is not backing off after homing this axis.
« Reply #1 on: January 21, 2014, 10:48:37 AM »
Is there an error message? Is the axis "Ref'd" after it hits the switch? It's only supposed to back up enough for the switch to open.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: My X home switch is not backing off after homing this axis.
« Reply #2 on: January 21, 2014, 12:20:16 PM »
The error message only pops up if I attempt to home it again after doing the homing once. The error message is something to the effect of- limit switch is activated, please deactivate limit switch before homing machine.

The only reason I found that it is not moving off the X axis home switch is that you can hear it move off the Y switch, and I did not hear it move off the X switch. Sure enough, when looking at the switch , the x axis does not preform the move off of it.

Any thoughts?

Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: My X home switch is not backing off after homing this axis.
« Reply #3 on: January 21, 2014, 12:55:33 PM »
Does the Ref LED light up?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: My X home switch is not backing off after homing this axis.
« Reply #4 on: January 21, 2014, 12:58:47 PM »
Is the ref led the box around the X, Y, Z, or 4 that turns green? (on the program run page)

Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: My X home switch is not backing off after homing this axis.
« Reply #5 on: January 21, 2014, 01:09:04 PM »
yes
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: My X home switch is not backing off after homing this axis.
« Reply #6 on: January 21, 2014, 01:12:38 PM »
I am not in front of it, but I remember that the Y RefLED will turn green and the X RefLED does not.

So, does that mean it is not completing homing the X even though it is tripping the switch? I know the switch is being activated as it stops at it and the M1Home and M2Home leds on the diagnostics page are both lit after homing.

Re: My X home switch is not backing off after homing this axis.
« Reply #7 on: January 21, 2014, 05:32:56 PM »
I take it back. The ref leds indeed do turn green, both Y and X.
Re: My X home switch is not backing off after homing this axis.
« Reply #8 on: January 21, 2014, 07:47:46 PM »
A bad switch (contact bounce)?  Try changing it.
John Champlain

Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: My X home switch is not backing off after homing this axis.
« Reply #9 on: January 21, 2014, 08:59:43 PM »
Yes, it sounds like the switches is opening and closing again.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html