Hello Guest it is February 27, 2021, 02:19:30 PM

Author Topic: GCode problem  (Read 4517 times)

0 Members and 1 Guest are viewing this topic.

GCode problem
« on: January 15, 2014, 03:14:35 PM »
Can anyone see where I am going wrong with this Gcode generated with Solidcam. It should simply milling two circles of just over 100mm each with a 6mm cutter, but when I try to load the Gcode I get a warning about soft limits. I can jog past the area where the material is so I'm not sure what the issue is. Can you see what I've done wrong??

Code: [Select]
%
O5000 (F_CONTOUR1.TAP)
( MCV-OP ) (15-JAN-2014)
(SUBROUTINES: O2 .. O0)         
G90 G17
G80 G49 G40
G54
G91 G28 Z0
G90
M01
N1 M6 T1
(TOOL -1- MILL DIA 6.0 R0. MM )
G90 G00 G40 G54
G43 H1 D31 G0 X123. Y59. Z50. S1000 M3
M8
(--------------------)
(F-CONTOUR1 - PROFILE)
(--------------------)
   X123. Y59. Z10.
   Z2.
G1 Z0. F33
   Y61. F100
G3 X121. Y59. R2.
G2 X121. Y59. I-62. J0.
G0 Z10.
   X253.
   Z2.
G1 Z0. F33
   Y61. F100
G3 X251. Y59. R2.
G2 X251. Y59. I-62. J0.
G0 Z10.
M30
%

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: GCode problem
« Reply #1 on: January 15, 2014, 03:37:59 PM »
Could be the G28 or it could be your height offset if you have any set in the tool table. Which axis is the warning for?
Hood
GCode problem
« Reply #2 on: January 15, 2014, 03:45:52 PM »
I've nothing set in the tool information window, the status says "soft warning on X min"
GCode problem
« Reply #3 on: January 15, 2014, 03:56:31 PM »
I tried running the program and ignored the soft limit (with the bed wound down to cut fresh air) and the path it was taking was massive, much greater than the 120mm expected. I guess this is a solidcam issue?
Re: GCode problem
« Reply #4 on: January 15, 2014, 04:00:27 PM »
just a guess at the moment, but my mach3 machine is setup in mm, and the drawing in solidworks was in mm, but I'm guessing solidcam created the gcode in inches, even though its set to metric in the options?

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: GCode problem
« Reply #5 on: January 15, 2014, 04:06:12 PM »
Have a look at your machine coords and see where your Z0 is.
Are you homing the mill?
The code is not defined as far as metric or imperial, ie no G21 or G20 in it so it will run in whatever Mach is currently set to, you will see that at the top of the main screen, either G20 (Imperial) or G21(Metric)

Hood
Re: GCode problem
« Reply #6 on: January 15, 2014, 04:39:28 PM »
Yes I have homed the mill,  at the top of screen it says G21 so I guess that's ok.

I have attached a screen shot, looking at the table display window on the right, it looks like it's creating a circle within a circle, what I was expecting was two circles next to each other.
Re: GCode problem
« Reply #7 on: January 15, 2014, 04:41:03 PM »
Here is a screenshot of what I thought I was creating gcode for, to keep things simple I was just trying to cut the two centres from the circles (shown in yellow). Does this look like more of a post processor problem to you??

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: GCode problem
« Reply #8 on: January 15, 2014, 04:49:35 PM »
I would say you are Absolute IJ mode and it should be Incremental. Go to General Config page and change the default then regen to toolpath.
Hood
Re: GCode problem
« Reply #9 on: January 15, 2014, 05:07:49 PM »
Wooohoo!!! legend!!! Thanks again so much Hood, that looks much different now