Hello Guest it is January 26, 2020, 09:20:41 PM

Author Topic: Homing/Limits  (Read 3822 times)

0 Members and 1 Guest are viewing this topic.

Homing/Limits
« on: January 15, 2014, 02:52:48 PM »
Is there a way to home REF a CNC router table at X+ Y+ rather then the std. X- Y- location limit switch locations. I understand that machine coordinates would be in neg values. Trying this I get a homing/ limit min>max error when a try to ref. the machine.  The odd thing to is that the Y jog direction flips direction after REF axis. I'd assume I would set my limits a neg numbers as well. My table has a 98 inch X axis travel and a 52 inch Y axis. I'd like to park the gantry at the X+ Y+ location as it is out of the way in that corner of the shop. You can see the DIY router table on youtube just seach for "ShadeTreeCNC"   or a link http://www.youtube.com/user/ShadeTreeCNC any help would great!

Rich Moller

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Homing/Limits
« Reply #1 on: January 15, 2014, 05:01:58 PM »
If you go To Config > Homing/Limits, and uncheck "Home Negative" for those axis, then it will home positive.
If you set a Home Offset of 98 for the X and 52 for the Y, then your machine coordinates will be positive, with 0,0 in the lower left, but Home in the upper right
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Homing/Limits
« Reply #2 on: January 16, 2014, 03:58:40 PM »
Thanks for the reply that makes perfect sense. Now a follow on question: I can only assume that the soft limiits are in relation to the now zero / zero position and not the home position. So now do I need to have my work coordinate inside the soft limits area before toggling in on on the run screen? Soft limits set as .5 = min and 97.5 max for X axis and .5 = min and 51.5 max for Y axis. I'm also assuming I'd need to toggle soft limits off before REF home.

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Homing/Limits
« Reply #3 on: January 16, 2014, 06:20:36 PM »
Personally, I would modify the homing macro to do the following:

1) Turn off softlimits

2) Ref the axis

3) Move away from the switches inside the softlimit zone

4) Turn Softlimits back on.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Homing/Limits
« Reply #4 on: March 16, 2014, 01:41:21 PM »
Is there a way to make 1 axis return to a user defined zero (work piece zero) without offsets.

Also, is there a way to wire in another limit switch that halts/stops the travel? I have proximity switches, not mechanical limit switches right now and when manually jogging I can go right past the switches and have already accidentally ran my slides off the linear rails, thus pulling oil lines out. I was able to get everything back together but I want to make this fully dummy proof for myself.

Thanks,
Whizbang

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Homing/Limits
« Reply #5 on: March 17, 2014, 09:09:43 AM »
The returning to zero is most likely achievable though I couldn't tell you how to do it.

In regards to the switches, proximity or other kinds. Do you have the switch enabled as a home switch? As a limit switch too? Both types will need to be enabled though you only run 1 physical switch. Look into running "soft limits" too. This will keep the machine within its physical boundaries.
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)
Re: Homing/Limits
« Reply #6 on: April 23, 2014, 02:13:18 AM »
After many years of running my router I decided to add homing and limit switches. It seemed ok when I tested the switches and connections to Mach3, diagnostics shows homing OK.
But when I tried to use homing cycle, Z and Y were ok but X had a problem. There I have main X axis and B as a slave. For some reason slave is not driven during the homing cycle.
Gantry is not moving, just making terrible sound. Looking at the forum I did found some reference to this in 2007. I have downloaded the latest version R3.043.066 but it did not make
any difference. I assume there must be a solution to this issue. I hope someone can point me in the correct direction. Thanks
Re: Homing/Limits
« Reply #7 on: April 23, 2014, 03:18:29 AM »
Just found the solution to my question. There is a small window under General Logic Configuration which I did nit tick, This activates Home Slave  with Master :D