Hello Guest it is November 19, 2019, 11:50:46 PM

Author Topic: Newfangled Wizards Change Machine Units  (Read 3368 times)

0 Members and 1 Guest are viewing this topic.

Newfangled Wizards Change Machine Units
« on: November 19, 2013, 03:33:53 PM »
I'm new to using Mach3 and the Newfangled Mill Wizard and have run into a problem I can't figure out.  My machine is set up with inch units and when I try to run the Mill Wizard for some reason the machine units are changed.  They appear to be divided by approximately 25 (rough measurement but strangely close to a metric conversion).  To better explain, when I first start the machine and Mach3 and manually jog the table axes, the DRO (in Mach3) and actual table movements match.  After I run the Mill Wizard for a test job, I find the table motion is about 25 times greater that what is indicated by the DRO .  When I run the G Code, the machine tries to go to the commanded position, but since the scaling seems to be off by 25 it runs to the table stops (x, y and z).  If I restart Mach3 the issue is corrected, but comes back as soon as I run the wizard. 

Any suggestions?    ???

Thanks,

NZ
Re: Newfangled Wizards Change Machine Units
« Reply #1 on: November 19, 2013, 04:18:46 PM »
could it be 25.4 times greater ?
« Last Edit: November 19, 2013, 04:24:38 PM by angel tech »
Re: Newfangled Wizards Change Machine Units
« Reply #2 on: November 19, 2013, 04:47:27 PM »
Yes it was 25.4.  Turns out that the "native units" in the configuration was set for mm instead of inches even though all the motor set up was configured as inches.  When I selected the inches option the problem was solved.
Re: Newfangled Wizards Change Machine Units
« Reply #3 on: November 19, 2013, 05:00:20 PM »
The wizard can generate code in inch or metric units. There is a setting on the first page to select. Be sure it is set to the units you use. The wizard also saves all settings from a session, so if you set it once to metric it will remain that way until you change it.
 
Re: Newfangled Wizards Change Machine Units
« Reply #4 on: November 19, 2013, 05:49:45 PM »
Yes it was 25.4.  Turns out that the "native units" in the configuration was set for mm instead of inches even though all the motor set up was configured as inches.  When I selected the inches option the problem was solved.

Spot on, isn't it great when you get it sorted...