Hello Guest it is November 20, 2019, 04:39:20 AM

Author Topic: Problem editing G-code  (Read 2082 times)

0 Members and 1 Guest are viewing this topic.

Problem editing G-code
« on: November 17, 2013, 01:55:44 PM »
Hi all,

I am new to this forum and Mach3 and I am hoping someone can help me with a problem editing G-code. I have a Raytheon model 500, 300 Watt Yag Laser Welder with a Bandit controller. I am in the process of swapping out the Bandit with Mach3. So far everything is going well except when I download a program and need to edit it I get a message box that flashes on and off. The message box is labeled "Path Generation" and the dialog in the box says "Generating Path". I have a trial version on my laptop that allows me to edit G-code so I matched the settings for Config>Ports and Pins, motor Tuning and General Config that are on my laptop to the licensed version on my PC but I still get the message. I checked the files and none of them are marked "Read Only" "Hidden" or "Archive" so I am stumped and hoping someone knows what I have done wrong.  Thank you in advance for any help you can give me.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Problem editing G-code
« Reply #1 on: November 17, 2013, 04:42:11 PM »
Sounds like maybe your keyboard or mouse is problematic and when opening the code it is  somehow automatically being closed again and thus reloads in Mach.
Hood
Re: Problem editing G-code
« Reply #2 on: November 18, 2013, 10:28:09 AM »
Hood,

I changed the Mouse and Keyboard but it still won't let me edit G-code. I did notice a couple things. When I select edit G-code it flashes the same information box as if I had selected "Regen Toolpath" and performs the same steps. Also the "Cycle Start" button lights up momentarily when I press Edit G-Code or Regen Toolpath, is it supposed to do that? I guess worst case scenario is I edit G-Code on a different computer then download and run it on my licensed version. Thank you Hood for all of your help.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Problem editing G-code
« Reply #3 on: November 18, 2013, 10:52:32 AM »
Are you using a custom screenset? Sounds like the Edit Code button may actually be set up as the Regen button.
Hood
Re: Problem editing G-code
« Reply #4 on: November 18, 2013, 11:36:59 AM »
Hood,

I haven't tried to alter or modify to a different screen set yet so I don't think that is the problem. I used the search feature to look for someone else having a similar problem and found a post that you helped with concerning G-Code Editor. I had WINNT\Notepad.exe as the editor. When I switched the G-Code Editor to C:\WINDOWS\system32\notepad.exe everything started working properly. Thank you so much Hood for all of your help.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Problem editing G-code
« Reply #5 on: November 18, 2013, 01:26:10 PM »
I had thought of that initially but didnt think it would behave as you mentioned if the wrong editor was in the link, but glad you got it sorted :)

Hood