Hello Guest it is June 16, 2019, 09:36:14 PM

Author Topic: soft limits out of range  (Read 3247 times)

0 Members and 1 Guest are viewing this topic.

soft limits out of range
« on: October 18, 2013, 01:13:33 PM »
My router has a useable table size of x16 inches by y24 inches. I don't have any limit switches.
My part created in Mastercam is X13 inches by Y17 inches.
After setting the soft limits to be several inches larger than my part, I then tried to activate the soft limits switch.
I got a message that the soft limits are out of range.
On the upper right corner of the toolpath screen in the "program limits" window it shows that the limits for the X axis are -375.8937 +4.4860.
I have 3 other parts (all created in Mastercam) thatl show equally goofy program limits measurements.
I have no problem machining the parts; I just don't have the safety of knowing I have soft limits.
Does anybody have a solution?
Thanks.

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: soft limits out of range
« Reply #1 on: October 18, 2013, 03:35:41 PM »
To be able to use Soft Limits you have to home your machine so that Mach knows where it is.
 If you do not have home switches you can still do it by jogging to a known position and pressing RefAll,  but it is best to have home switches.

Hood
Re: soft limits out of range
« Reply #2 on: October 18, 2013, 07:27:47 PM »
Dear Hood,
I am new to CNC and Mach 3, but I have machined several parts with no problems.
Here is what I do;
I open config> homing/limits, and enter the dimensions that are 1 inch smaller on all sides than the table is.
I jog to within 1 inch of the -X and -Y table size and +3 Z axis inches. I click Ref all Home.
I load the Gcode, and jog to the start point of my part. I zero all axis. I click soft limits.
When I Cycle Start, a message comes up warning me about being out of range and the option to proceed anyway. If I click OK, it will proceed to machine the part without using soft limits.
My problem part is much smaller than the soft limits.
On the Toolpath Screen, in the display window which on my computer is black, there is a Grey colored band that goes 375 inches in the -X direction. That is the program limit. This only happens with this part and 3 other parts.
I have no problem with soft limits while cutting parts that are larger than this problem part.
All the other parts show in the "Program Limits Absolute Coordinates" window the actual dimensions of the part. This problem part which is 13 X 17 inches shows in the "Program Limits Absolute Coordinates" window to be -X 375.8937,and +4.4860.  The Y Axis shown is the actual dimension of the part.
lstiver53

 

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: soft limits out of range
« Reply #3 on: October 19, 2013, 05:00:43 AM »
Soft limits are really meant for stopping your machine from going beyond its travel extents and not for parts.
Ideally fit some home switches, it is not hard to do and depending on the accuracy required can be relatively cheap. If you use optical switches such as Optek OPB916B it will give you excellent repeatability as well as them being cheap. The downside is you need to shield them from dust/liquid etc.

If you decide not to use home switches then what you will have to do is

Move fully negative on X and Y and fully positive on Z
Press Ref All button. (that tells Mach where machine coords zero is)
In homing and limits set X and Y min and Z Max to Zero
Set X and Y Max to your axis travel distance and set Z Min to the axis travel distance but as a negative value.
You now have soft limits set up and can enable them.

To start a job just jog to where you want the offset zero to be (part zero) and press Zero at the side of the axes DROs, you have now just set up a work offset.


Each time you start Mach you need to home or Mach has no idea where it is so if you dont have home switches you will have to do as above.

Hood
Re: soft limits out of range
« Reply #4 on: October 20, 2013, 02:05:54 PM »
I don't have any problem setting soft limits with any parts other that my 4 problem parts, of which all 4 are much smaller than my machine limits.
So, I will just have to live with the problem which is not that big a deal anyway.
I will consider this topic ended.
Thanks
lstiver53

Offline ger21

*
  • *
  •  6,260 6,260
    • View Profile
    • The CNC Woodworker
Re: soft limits out of range
« Reply #5 on: October 20, 2013, 02:47:32 PM »
Your problem is with MasterCAM. Learn how to set the origin to the correct place in MasterCAM.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html