Hello Guest it is November 22, 2019, 10:58:06 AM

Author Topic: rutex drive with cnc4pc breakout board  (Read 2540 times)

0 Members and 1 Guest are viewing this topic.

rutex drive with cnc4pc breakout board
« on: February 26, 2007, 08:03:35 PM »
 
i have a strange problem with the 2020 drives . when i use the tuning software i can get the motors to run well. the parallel cable is connected straight to the computer. when i use the cnc4pc optoisolated breakout board between the pc and the 2020, the motors run very rough and erratic when trying out in mach3. connecting the parallel cable straight from the computer and 2020s in mach3 , they run silky smooth. does the optoisolation not work with the rutex products?
i assumed that the breakout board would provide a "cleaner " signal for the drives.

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: rutex drive with cnc4pc breakout board
« Reply #1 on: February 26, 2007, 09:57:27 PM »
Hi, Najnielkp

This may be a leading low, leading high issue with your OPTO Isolator board.

Try setting In Config, Ports-Pins, Motor Outputs Changing your Dir, STEP LowActive setting to Opposite state, X to Check or Check to X.

Some controls are sensitive to leading and trailing Edge Pulse's.

Try this one First, It could also be In Config, Motor Tuning the Pulse Width set to low, Step, Dir Pulse's, If there set to 0 set them to 5,

If that fixes it, back them down till problem then backup 1 level. ( time that the Opto's have to see Mach Pulse's.

Hope this Helps, Chip
« Last Edit: February 26, 2007, 09:59:02 PM by afn09556 »
Re: rutex drive with cnc4pc breakout board
« Reply #2 on: February 27, 2007, 12:25:05 PM »
i think i found the problem. looking at the specs for the cnc4pc breakout board , shows a maximum input of 10 khz. output of 200 khz. try to jog any faster than 60 ipm and the thing is maxed out for speed. 

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: rutex drive with cnc4pc breakout board
« Reply #3 on: February 27, 2007, 01:00:52 PM »
Hi, Najnielkp

Did you try items in my Previous post.

Thank, Chip
Re: rutex drive with cnc4pc breakout board
« Reply #4 on: February 27, 2007, 02:44:35 PM »
hi, yes i did. tried configuring the pin outputs for different ways , same thing . changed the length of the step and direction to 5 us  did not work. thank you for your help.i will just remove the brealout board and connect direct to the rutex motherboard.