Hello Guest it is November 22, 2019, 08:36:03 AM

Author Topic: Can't MACH3 execute faster??? Please help  (Read 4982 times)

0 Members and 1 Guest are viewing this topic.

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
(No subject)
« Reply #10 on: September 30, 2013, 08:23:46 PM »
They are telling you, your settings are limiting you. Not the machine. Or that remains to be seen if your XML was provided.
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Can't MACH3 execute faster??? Please help
« Reply #11 on: October 01, 2013, 02:05:37 AM »
It would actually execute slower on the real machine as there is a tool call in the code and that would make my machine move to the toolchange position, so probably 1 or 2 seconds slower.
I used my motor tuning values in your profile and it took 41 seconds but that is because you have a 1 second  spindle delay set.

I looked at your profile and you have pin 10 for both step and dir on X, Y and Z, you also have 20 for both step and Dir pins on B, that is not right.
Your motor tuning does not reflect the screenshots you had above either so I am thinking you have attached the wrong xml.
The xml says you are using the printer port, is that what you are using? or are you using an external controller?

Hood
Re: Can't MACH3 execute faster??? Please help
« Reply #12 on: October 01, 2013, 03:42:27 AM »
It would actually execute slower on the real machine as there is a tool call in the code and that would make my machine move to the toolchange position, so probably 1 or 2 seconds slower.
I used my motor tuning values in your profile and it took 41 seconds but that is because you have a 1 second  spindle delay set.

I looked at your profile and you have pin 10 for both step and dir on X, Y and Z, you also have 20 for both step and Dir pins on B, that is not right.
Your motor tuning does not reflect the screenshots you had above either so I am thinking you have attached the wrong xml.
The xml says you are using the printer port, is that what you are using? or are you using an external controller?

Hood


I've attached the XML again.

The XML is just the same as on the first screenshot in the example. I have fixed my PIN numbers, so that they are the same as those I am using with my real machine.

Yes, I am using the LPT Port (printer port) of my PC to send the signals to my motor drivers. I have three stepping motor drivers, each of them recieve signals directly from my LPT port.

Maybe, this is the constraint? Maybe LPT Port just cannot work faster?
Re: Can't MACH3 execute faster??? Please help
« Reply #13 on: October 01, 2013, 04:46:41 AM »
Looks like I've found what was the issue.

The constrant was in the port I've been using. First I've been testing on the LPT port where my real CNC was connected, then I've started testing on my PC where there is no LPT port. So on the PC with no LPT port looks like MACH3 was using some kind of printer port. That's why the speed was never more than 1min 16sec. I went then to my PC with LPT port, and inputed astronomic values in MACH3 and it was able to execute in 24 seconds.
Still, there is a limit to my LPT port, but it is enough for me.

Interesting, do you use LPT ports as well, or there are much better controllers for this function?

I've attached the XML file from my PC with LPT port, if what.

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Can't MACH3 execute faster??? Please help
« Reply #14 on: October 01, 2013, 05:44:48 AM »
I suspected from the start of this post that something didn't add up and now it's clear. You're using a pirate license.

You'll get no more help here. If you feel this is in error then you should contact licensing. Until then you're banned.
« Last Edit: October 01, 2013, 08:26:15 AM by stirling »