Hello Guest it is July 14, 2024, 02:52:10 AM

Author Topic: Minitech Mill2  (Read 7006 times)

0 Members and 1 Guest are viewing this topic.

Minitech Mill2
« on: November 02, 2007, 08:00:07 PM »
I'm a newbee trying to set-up a mill2 to run.  Does anybody have experience with one of these?  My motors power up an lock in place when the power is turned on.  The parallel cable has been checked and there are no rerouted wires.  I'm using a laptop with XP but the output looks to be about 4.74 V on each pin that has power.  When jogging the software it seems as if my pins 678 change but I don't see pulsing or anything that I can correlate to a specific axis.  It seems like the 10-14 and 15 pins may always be on.  The biggest question is what pins do I really need to use for a Mill2????  I can't get ahold of anyone at minitech.  Does anyone know what the serial port on the control box are for?  I'm assuming the lpt port is what I should be using for control, and the serial port is for signals to the pc?

I have a lpt dongle that came with the computer that seems to have one pin rerouted but I'm not sure what I use it for?

Any comments or information would be a big help!,  Thanks, Todd
Re: Minitech Mill2
« Reply #1 on: November 04, 2007, 02:08:54 PM »
I never used a laptop with Mach3 and from what I read it's better to stay with desktop pc's.  What type of breakout board does it have (the board that pPort cable connects to)?  Do you have a desktop pc to test run the mill with? 
Re: Minitech Mill2
« Reply #2 on: November 04, 2007, 03:43:42 PM »
I took a step back and found a WinME2 laptop that when plugged in using some DOS control software immediately controls the y and z axes.  However, for some reason I am not getting control of the x axis.

This is un-Mach3 related but here's what is happening:  The motors locks up when the power is to the controller board but when the lpt cable is plugged in all motors don't seem to be locked.  The z and y axis seem to jog just fine.  When I try to control the x axis I hear slight noise and it's like the motor starts to move/deflect and then settles back to it's original position.  I switched the stepper motor wires from the working y-axis motor and had the same result so it's probably not my stepper that is the problem.

Any suggestions on how to diagnose the motor side of the controller board?  One interesting thing is that with the new laptop the "off" state is about 0.2 V instead of 0.0 as with the newer laptop.

My lpt cable is a direct cable so nothing getting switched around.
Re: Minitech Mill2
« Reply #3 on: November 04, 2007, 09:48:10 PM »
It is not possible for a stepper motor not to locked when power is applied to the drive, unless there is a enable input on the drive and when you plug in the pport cable is disables the drive.
But you say they jog fine so I guess there is no problem there.

Put up some pictures of the motor controllers to get a better idea of the setup.

Do you have the wires from the X drive to the stepper connected properly? 
Re: Minitech Mill2
« Reply #4 on: November 04, 2007, 10:44:01 PM »
Here is some more info before I can get some pics for you:

I had my 3 1/2 year old son control the motion using the minitech software (cpmill.exe running in WinME 2nded) and I checked the output at the lpt cable where it connects to the controller.  That was fun.  He loves the machine.
I get the same response, 3.58 V when the motor should be at rest and 4.26 V when active for pins 3, 5 pand 8.  I also get high response in one direction for each of 4, 6, and 8.
The odd thing is that if I unplug the lpt from the controller the motors are "locked up"  when I plug it back in the motors (y and z) are controllable but I can spin the lead screw by hand.  This doesn't seem right?
I went back and made sure the x stepper motor works by controlling it with the y output on the controller, so all my steppers are good.
My board is a PC1001 rev A, I checked the voltage at the UNC5804B's when I was controlling y and z and found about 0.75 v when the stepper was moving and 0 at rest.  For the X axis though I was reading 4.98 V always.  Does this mean the MM74HC14N is bad or is the 5804B at "U14" bad?

Basically it seems that something is amiss after I get to the controler board but I'm not sure where.  It is definitely at or before the last chip before the stepper?
Re: Minitech Mill2
« Reply #5 on: November 05, 2007, 09:26:23 PM »
Thats not good if you can easily spin the screw by hand, that means the motors don't have much power. 

You didn't pay $7K for the machine did you?

Contact the guy on this thread (pminmo, phil)

He builds a lot of stepper drives and will be able to give you better directions.

Re: Minitech Mill2
« Reply #6 on: November 07, 2007, 10:11:30 PM »
I tried the link and it seems like all the links lead to nowhere.  Thanks for the help though!

I've pretty much narrowed my problem down to a couple points on the controller board.  It's tough to diagnose with out diagrams though.

My Dad bought it on eBay from a guy named Daniel Ale on eBay as a ready to run CNC machine with software...but he forgot to send the passwords and when we finally get it running in DOS and the controller is bad!

What do you recommend for a controller card for 3-axes?  I do have a good DC power supply and steppers so it shouldn't be a big deal to retrofit the good parts I have.  That guy you recommended I contact had some DIY components that seemed like it would be fun to try to start building one with but I wouldn't mind spending a couple hundred to get something decent.

Offline Chip

  • *
  •  2,055 2,055
  • Gainesville Florida USA
Re: Minitech Mill2
« Reply #7 on: November 07, 2007, 10:52:06 PM »
Hi, Kurtht

Hears a typical diag. of a UNC5804B IC, Pin 15 is used to Enable/Disable the output, Gnd Enables it.

Hope this Helps, Chjip
Re: Minitech Mill2
« Reply #8 on: November 08, 2007, 03:08:17 PM »
I haven't tried these drives but should work nice with your motors if they are setup for bipolar:

How many wires do you have from stepper the motor?