Hello Guest it is June 18, 2019, 01:48:51 AM

Author Topic: Phantom Limit switch activation in the middle of a build.  (Read 1817 times)

0 Members and 1 Guest are viewing this topic.

Phantom Limit switch activation in the middle of a build.
« on: September 08, 2013, 09:51:11 PM »
Hi,

I am having trouble making it all the way through a program because somewhere in the middle of a build a limit switch is triggerd and stops the program - The problem is, I don't have any limit switches installed......

Heres how the problem plays out.

I am using a Taig Micromill with Mach3 running G code generated by Meshcam. The parts I (try to) make are only 1 inch by 1 inch out of aluminium, so there is no way that any limits are even close to being exceeded.

I set the zero's the the edge of my stock and begin the program. The mill works great for about 45 minutes, cutting out a fantastic looking part. Then for no reason the spindle stops, and Mach 3 gives me an error message "A limit switch has been triggered",

I dont have any limit switches installed so why would I get this message??

Thats not even the biggest problem....

The big issue I have is that after I reset, and recommence the program, Mach skips about 1000 lines of code, tries to dig way too deep and breaks bits. Even if I rewind back to the same line of code that the limit switch was triggered on, the program runs through slightly offset from the original pocket, like somehow it has dropped its program zero.

So..

Can anyone tell me

1) How can I get Mach to ignore these phantom limit switch activations?, or
2) How can I get the program to continue and complete the part rather than spazzing out and breaking my endmills?

Thanks
Re: Phantom Limit switch activation in the middle of a build.
« Reply #1 on: September 09, 2013, 05:11:45 AM »
Hi Scott, suspect you have some interference so you could try on the config tab (general config and on right hand side of the page) disabling the watch dog box and put a de-bounce figure of 2000 in. If that doesn't work reactivate the watchdog as its best to have them on. This will allow Mach to try and over-ride the interference. As far a the loss of settings when the system is triggered the motors and your axis display loose the synchronisation (motors travel a bit further or stop early compared to the readout) hence the offset when you try to recut with sometimes a devastating effect on the Z minus reading as your machine is probably an open loop machine. If you have a machine reference point onto micro switches or setting block and know the distance from them to you component datum you can reset you datum's accurately but with out a physical machine reference you will find the datum's are not accurate after an emergency stop. That's why companies have a machine reference and link it to a component datum point. So try and set yourself a reference point on the table so you can set your zero's after a crash.
I my previous posts you will see I have had the same problem, in my case it was a faulty capacitor on my ancient (1988) spindle drive card interfering with the 5v control system, although at first I thought it was a new overhead fluorescent light I had just fitted.
I made myself a flow chart to work down to try and eliminate the interference if you want it?
Hope this helps
 
« Last Edit: September 09, 2013, 05:22:27 AM by jimthefish »
Re: Phantom Limit switch activation in the middle of a build.
« Reply #2 on: September 09, 2013, 08:13:47 PM »
Thanks Jim,

I have tried a lot of different settings, but not the Watch dog. I didn't know what it was so I didn't want to touch it.

Thanks for the suggestion, I will give it a go.