Hello Guest it is January 24, 2022, 02:26:48 PM

Author Topic: Can't figure it out!  (Read 4875 times)

0 Members and 1 Guest are viewing this topic.

Can't figure it out!
« on: August 30, 2013, 04:29:10 PM »
Tried using Mill Wizard to cut a 2" by 1" outside rectangle. The program it generates includes several circles that cut thru (2) corners of the rectangle. Any ideas why?
Re: Can't figure it out!
« Reply #1 on: August 30, 2013, 06:08:06 PM »
The wizard generates circular ramps down into the work, then does an arc in and arc out so the parts gets the best finish possible. It also does round corners if a corner radius is specified.

The circles should not cut into the finished part.

Please post the job file here so I can see exactly what you are doing.
Re: Can't figure it out!
« Reply #2 on: August 30, 2013, 08:48:49 PM »
Thais Ron, will send it ASAP.
Re: Can't figure it out!
« Reply #3 on: August 31, 2013, 05:47:33 PM »
Hi Ron, previous message should have said "Thanks". Yep, you guessed it, I'm a newbie. I purchased and converted a Little Machine Shop mill to CNC about 2 months ago and have avoided a lot of problems by searching these posts. bottom line, I really appreciate your help. I've attached the job file and gcode file. I anxiously await you help and suggestions.

AllenJ

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: Can't figure it out!
« Reply #4 on: August 31, 2013, 06:21:50 PM »
Could it be as simple as the machine is set for Abs not Inc IJ's and you are seeing crop circles. 

Just a thought, (;-)TP
Re: Can't figure it out!
« Reply #5 on: August 31, 2013, 11:52:20 PM »
TP,      You lost me. Can you tell what Abs and Inc IJ is?

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: Can't figure it out!
« Reply #6 on: September 01, 2013, 02:21:40 AM »
At the MDI line type in G91.1 then enter  . That will set Mach3 for INC IJ's.  If that fixes it then you need to go to Gen Config and set the IJ's for INC.

The INC/Abs setting tells mach3 HOW to deal with the arc commands, whether to base it on incremental values or Absolute values.

It is IN the manual (;-)

I ran the code here and it was fine IF set to Inc.  The Wizard SHOULD have set G91.1 in the Gcode when it Wrote the program BUT it did NOT put the code into the program. (bug)

 (;-) TP
Re: Can't figure it out!
« Reply #7 on: September 01, 2013, 08:48:48 AM »
The display in the wizard uses a fixed toolpath display and interpreter. The user has no control over its setting, at least at the present time. So this job should display correctly in the wizard, but could have a problem when loaded on mach3, depending on the IJ mode setting.

I agree the wizard should set G91.1 in its init code.

Another note on this job- the clearance height seems to be set a lot higher than needed. Note the long spiral ramp in air above the part Change Clearance in the new job screen to something close to the work, like maybe .050.
« Last Edit: September 01, 2013, 08:51:13 AM by Ron Ginger »
Re: Can't figure it out!
« Reply #8 on: September 02, 2013, 04:08:40 PM »
Ron, and TP

Thanks guys, changed IJ mode setting from Absolute to Inc and it works fine. really appreciate it. ;D