Hello Guest it is December 10, 2019, 01:38:10 PM

Author Topic: Mach3+Ethernet SmoothStepper+PMDX-122+M880 -> Moves exacly 0,2/0,3mm longer  (Read 3741 times)

0 Members and 1 Guest are viewing this topic.

Hello.
I was using my router for a almost 2 years now. But after I moved machine in the new shop I got a strange problem.
Every time I try to cut outside circle I get a circle axacly 0,2mm bigger. Every time I try to cut inner circle (hole) I get 0,2mm smaller. When I cut a square outside I get 0,3mm bigger.

So When I cut a circle with ø10mm on the outside I get 10,2mm. When I cut a hole ø3mm I get 2,8mm. When I cut a square 7x7mm I get 7,3x7,3mm.

My setup is:
Windows XP with 3ghz cpu.
Ethernet SmoothStepper
PMDG-122 Brakeout board
KL-8070 Stepper Drivers
2Nm Nema 23 motors (8-leads)
48V PSU capable of delivering 24A constant
Kress FME 1050W
ø16mm 1605 Ballscred an all axis
ø16mm Shafts with SMUU bearings

What I have tried:
1. I changed location of all cables.
2. I changed location of spindle cable.
3. Changes back and forth microsteps.
4. Calibrating steps per. But this is weird as it worked before.
5. Reinstalling (everything with newest drivers and versions)and setting up Mach3 and SmoothStepper for skratch.
6. Tried 3 different PCs included Laptop with Win7 64-bit. Each time new setup.
7. Screaming at whole system
8. Curse at whole system

What i suspect:
My new location has a little mote humility.
1. Maybe PMDX-122 is going crazy?
2. Maybe SmoothStepper is going crazy?
3. Maybe Stepper Motor Drivers are going crazy??
4. Some kind of Noise doing it? But noise is never so consistent.

Any more ideas?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Do you have backlash comp enabled?
If you attach your xml I will check it over, also what microstepping do you have the stepper drives set to?
Hood
I had log in problems so sorry for not writing before.
I don't have backlash enabled.
My microsteps are 1/16 and my motor tuning setup is 640 -> 3000 -> 400. So it schould not be a problem.

I will post XML as soon as I go to shop and fire up my Computer there.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Ok while I wait on your xml here is something to check, could your cutter be 0.2mm under the size you are thinking it is and programming for?
That would seem to be a plausible explanation as that would make OD circles 0.2 bigger and ID ones 0.2 smaller that you were wanting.
Hood

Offline rcaffin

*
  •  1,007 1,007
    • View Profile
Quote
could your cutter be 0.2mm under the size you are thinking it is and programming for?

Second thought (based on experience...) could you be mistaking an imperial cutter for a metric one (or vice versa)?

Cheers
Hm...
I don't think so.
Here is a program I am running:
(2D CONTOUR1)
(T1  D=1.5 CR=0. - ZMIN=-1.5 - FLAT END MILL)
G90 G94 G40 G49 G17
G21
G28 G91 Z0.
G90

(2D CONTOUR1)
M9
T1 M6
S10500 M3
G54
M9
G0 X-0.75 Y3.5
G43 Z15. H1
Z1.
G1 Z-1.5 F150.
Y7. F300.
G2 X0. Y7.75 I0.75 J0.
G1 X7.
G2 X7.75 Y7. I0. J-0.75
G1 Y0.
G2 X7. Y-0.75 I-0.75 J0.
G1 X0.
G2 X-0.75 Y0. I0. J0.75
G1 Y3.5
G0 Z15.

M9
G28 G91 Z0.
G28 X0. Y0.
M30