Hello Guest it is May 28, 2020, 09:11:22 PM

Author Topic: 3020T estop not stopping the spindle  (Read 3000 times)

0 Members and 1 Guest are viewing this topic.

3020T estop not stopping the spindle
« on: August 15, 2013, 11:47:45 AM »
My boss purchased the small 3020T Chinese router and it came with the Mach3 controller software.  The problem I have is that the estop function stops the XYZ stepper motors, but not the spindle. :(  I don't know if it's something in the Mach3 set-up or maybe the spindle isn't supposed to stop due to Chinese safety standards being different.  There must be someone out there with this kind of experience that could lend a hand to a newbie.  Any help would be much appreciated.

Offline Tweakie.CNC

*
  • *
  •  8,265 8,265
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: 3020T estop not stopping the spindle
« Reply #1 on: August 16, 2013, 05:38:02 AM »
Try (Config / General Config) Pgm End or M30 or Rewind - checking the 'Turn off all outputs' and 'Turn Off Spindle' boxes and see if that cures the problem.

Tweakie.
KEEP SAFE !

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: 3020T estop not stopping the spindle
« Reply #2 on: August 18, 2013, 04:34:04 AM »
E-Stop should not rely on software to stop axes/spindle etc. It often is set up that way however, especially on home builds and cheap machines but it should be considered dangerous relying solely on software  for such E-Stop situations.
Having said that Mach should stop everything that it has control over when E-Stop is pressed, if the spindle is not stopping then either Mach does not control it or there is a config issue.
Attach your xml and also if possible some documentation to the machines setup (components) and maybe the issue can be found.
Hood
Re: 3020T estop not stopping the spindle
« Reply #3 on: May 25, 2014, 08:53:47 PM »
If you 3020T is like mine, there is no control over the spindle other than the manual ON/OFF switch provided on the front panel of the controller itself.