Hello Guest it is August 07, 2020, 12:00:55 AM

Author Topic: Mach3 problem with Huanyang VFD + 1.5Kw Water cooled spindle  (Read 3389 times)

0 Members and 1 Guest are viewing this topic.

Mach3 problem with Huanyang VFD + 1.5Kw Water cooled spindle
« on: August 06, 2013, 09:19:07 AM »
i buyed the Huanyang VFD + 1.5Kw Water cooled spindle ;

 I have configured the driver for the adapter and install the plugin that i found here http://royaumedeole.fr/informatique/...-huanyang-vfd/ connected with  usb cable RS485-USB to PC ;
infact when i open the Mach3 Version R3.043.066 the software confirm with a pop-up that "Configuration ok - spindle speed 3000 rpm at 50 Hrz" .
When i press F5 to start the spindle there is a click from the VFD and the estop of Mach3 starts flashing.

Huanyang VFD and 1.5Kw Water cooled spindle are OK ; infact if I leave in VFD Pid 001 and 002 to zero ( manual control ) the spindle strarts adn stops  withou problem

but if i set in VFD Pid 001 and 002 to two ( remote control with Mac3 ) the spindle don't start.

can someone hel me to solve the problem ?

thanks

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 problem with Huanyang VFD + 1.5Kw Water cooled spindle
« Reply #1 on: August 06, 2013, 11:29:53 AM »
Sounds like the VFD may be putting out a load of noise (electrical) and Mach sees the E-Stop being triggered because of the noise affecting the E-Stop input.
Best to have E-Stop Limits etc all properly shielded and the shield properly grounded to try and stop the noise getting onto these signals.
Another thing you could try is setting a fairly high Debounce Interval (General Config page)  try 2000 and see if that helps.
Be aware though that Debounce is just masking the problem and it is much better to cure it with shielding.
Hood