Hello Guest it is March 29, 2023, 10:13:25 AM

Author Topic: Strange feedrate problem!  (Read 2052 times)

0 Members and 1 Guest are viewing this topic.

Strange feedrate problem!
« on: June 01, 2013, 06:03:13 PM »
I've run into a feedrate problem that I just can't figure out.  I used BobCAD to generate a pocketing program for a 1/4" diameter pocket.  I plunge in at 4IPM and then cut at 11IPM.  The code looks good, but when I run the program the G02/03 cutting sequences crawl. For example:

G01  Z-0.1 F4.0                                                 Plunge to depth
G02 X-0.0003 I0. J-0.0177 F11.0                      Cut full circle

When I run the program, the Feedrate box on the Program Run screen show the programmed feedrate and the actual Units/Min.

As the plunge line is run, it shows the 4IPM programmed rate and an actual IPM of 3.64.
When the G02 line is executed, it shows the correct 11IPM programmed feedrate, but the actual IPM is crawling at 1.40IPM

Now the strange part.

If I run the program is Single Block Mode, the G02 line again shows the 11IPM programmed rate, but the actual is 10.64IPM which is what I would expect.

I am running CV mode and this could have something to do with it, but it's working fine on all my other programs.  I don't want to start blindly changing settings and was wondering if this behavior rings a bell with anyone.
Bill (the Cat) Shubert
Re: Strange feedrate problem!
« Reply #1 on: June 02, 2013, 04:17:02 PM »
I may have found my problem.  I checked the version change log and found a "bug fix for some Arcs feedrate" in Version 3.042.021 (I'm using 3.042.020).

I installed the latest lockdown version to my laptop as a simulator and ran my program.  It it appears to work correctly.

I haven't updated the computer connected to my mill yet.

If I copy the Mach3 folder before I update, can I revert to the old version by simply copying the old folder back in place or does the install modify the registry as well?
Bill (the Cat) Shubert