Hello Guest it is July 08, 2020, 08:00:12 AM

Author Topic: Axis Mixing Issue  (Read 4128 times)

0 Members and 1 Guest are viewing this topic.

Axis Mixing Issue
« on: May 29, 2013, 12:02:24 AM »
Hello All,

I must first confess that I am very new to CNC machines, but I hope to become a pro with a little patience and advice from the experts. I am having an issue wherein Mach3 seems to be mixing my axes. What I mean by this is the following:

1) My z axis is being treated by Mach 3 as my x axis.
2) The x & y axes are being treated as only my z axis. For example, when I press the pg up and pg dwn keys, the axes jog together at a diagonally at an equal rate across my mill.

I am sure this is simply a setting somewhere in Mach 3 that is easy for the experts, but I just can't find it. However, if that is not the case, I would be happy to provide some more background information about the setup procedure I used and the hardware as well. Lastly, I apologize if I am asking my question in the wrong section of this forum, but I did not see a particular place it belonged; therefore, the "General Mach Discussion" seemed to fit the best. Please feel free administrators to move this if it is posted in the incorrect discussion board.

Thanks,

Jacob

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Axis Mixing Issue
« Reply #1 on: May 29, 2013, 04:23:49 AM »
It sounds like you possibly have the ports and pins set incorrectly such that when you jog an axis two axis are set to the same output and you are getting both moving.
The other thing I can think it may be is you have one axis slaved to another.
If you attach your xml file for the profile you are using I will take a look. To attach your xml first thing to do is open Mach and then lower right note the name of the profile. Close Mach then browse to the Mach3 folder on your drive and look for a file of that name but with a xml file extension, right click it and choose copy then go to your desktop and in a blank space right click and paste. Then rename the file to jdstock.xml and finally use the additional options button on the reply page to browse to your desktop and attach the file.
Hood
Re: Axis Mixing Issue
« Reply #2 on: May 29, 2013, 10:50:24 AM »
Easy enough... My .xml file is attached. Also, I included a picture of my board so you could see its corresponding pin-out. I have check and rechecked those numbers a few times so I doubt they are wrong, but it would be just my luck.  :) Also, it may be relevant to point out that my driver board is a Hobby CNC driver board.

Thanks again for all the help!

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Axis Mixing Issue
« Reply #3 on: May 29, 2013, 05:19:40 PM »
Ok they look fine and no axis slaving, next thing to check is your parallel port cable, make sure it is not a cross over cable instead of a direct pin to pin cable.
Hood

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Axis Mixing Issue
« Reply #4 on: May 29, 2013, 05:29:31 PM »
One thing I have noticed is there are no axis hotkeys set for jogging. That may cause issues for you so if you go to config menu then System Hotkeys and then set the keyboard arrows up to your axes.
For example click the X++ bitton in system hotkeys then a box will pop up telling you to press a key, press the right arrow. Next move on to X-- and press left arrow, same for Y and Z. Z Hotkeys are PgUp and PgDn as standard.

Hood
Re: Axis Mixing Issue
« Reply #5 on: May 30, 2013, 12:39:38 AM »
Parallel cable is straight through; there are no issues there. I assigned the hot keys as instructed but no change in behavior. I kind of anticipated this being the case, as I had entered g-code into the prompt and I got the same results as using the hot keys.

So the quest continues! I feel a little better knowing that it was not something super easy thus far.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Axis Mixing Issue
« Reply #6 on: May 30, 2013, 02:47:44 AM »
It has to be a problem with either the wring or the breakout board, assuming of course Mach is showing the correct axis movement and not showing the dual movement that you are actually getting.
Hood

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Axis Mixing Issue
« Reply #7 on: May 30, 2013, 04:28:24 AM »
Max NC-10 wave drive is ticked. ;)

Ian

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Axis Mixing Issue
« Reply #8 on: May 30, 2013, 05:03:09 AM »
Looks like my decision to get the eyes tested yesterday was the right thing to do. Roll on Monday when I get a  shiny pair of milk bottles to hang from the lugs :)
Hood
Re: Axis Mixing Issue
« Reply #9 on: May 30, 2013, 08:57:41 AM »
Excellent! Thank you so much Ian! It now works as desired. I am having some other issues, but for now I will read literature to see if I can find the answers there rather than plaguing you all with questions. I'll post anymore questions if I can get it resolved.

Thanks again,

Jacob