Hello Guest it is December 16, 2019, 02:07:49 AM

Author Topic: ABC's of YOOCNC 6040Z Setup  (Read 29861 times)

0 Members and 1 Guest are viewing this topic.

Re: ABC's of YOOCNC 6040Z Setup
« Reply #10 on: December 30, 2015, 08:18:41 PM »
Hi mate,

Sorry to hear that, you are still having troubles but, 2 things you mentioned that will be important to mention...!

The very first one is that, when the controller is off, the motors should turn very easily, and as you said BUT, if the controller and mill are communication right, as soon as you turn the controller ON, the motors (all of them) should lock and you shouldn't be able to turn the knobs at all, in fact, you can hear the "knock" sound from the motors, when the controller is switched on.

As for the inability to get the axis to move from your computer keyboard, that was exactly what happened to me when, I tried to used my Toshiba laptop with Windows XP, this was what I intended to use with my CNC because I purchased a USB machine however, and after all attempts, I decide to try a old desktop computer I had also with windows XP, and as soon as I did that, the keyboard become alive when the Mach3 software is open on the computer screen, all axis started moving as they should.

I suggest that, you try to find another desktop computer with the old Windows XP installed and try to connect the controller to it.  It may be something not right with the desktop computer you are using now, you don't have anything to lose by trying another computer and see what happens.

ANd while talking of computer communication with the CNC controller, I just remembered that, you have to set the Mach3 software to the correct port of your computer and you have to make sure, that port is active.

It seems to me that, the controller and computer are not communicating and that,is all part of the "Ports and Pins" initial settings when the Mach3 software is downloaded into the computer shown on page 28 of the PDF file I sent you, the one that says "CNC-6040-Router-Engraver-System-Installation-Manual - Parallel"

There are also a number of YouTube clips made by the Mach3 team and they do explain well all the steps require, I don't recall with clip mentions this info but, you will be able to find it buy looking on this link, https://www.youtube.com/results?search_query=mach3+cnc+control+software+tutorial

Good luck and Happy New Year..!
George

Offline Sabre

*
  •  11 11
    • View Profile
Re: ABC's of YOOCNC 6040Z Setup
« Reply #11 on: December 30, 2015, 09:26:30 PM »
UPDATE

Well I did say the solution would be simple.  I deleted the MACH3 software and then reinstalled it WITHOUT the cable connected to the controller. Once completed, I rebooted the PC to make sure the settings stuck, then turned off the unit. Plugged in the controller to the PC and then rebooted. Now i have keyboard control.  Scared the crap out of me when it took off. I was not expecting it to work. :)  Thanks for the help and suggestions.

Offline Sabre

*
  •  11 11
    • View Profile
Re: ABC's of YOOCNC 6040Z Setup
« Reply #12 on: January 02, 2016, 05:32:10 PM »
We are still unable to get the spindle to control via Mach3 software.  Not sure if it is a setting within the Mach3 or a setting within the controller that needs to be changed. I can control the spindle if I put it in local run on the controller as the video shows

Any help on how to get the Mach3 software to run it or what controller function needs to be changed to allow it, would be greatly appreciated.

Thanks in advance
Re: ABC's of YOOCNC 6040Z Setup
« Reply #13 on: November 06, 2017, 07:37:36 PM »
Sabre,
I am in the same boat... I picked up a chinacnczone 6040z second hand (brand new never used, the guy couldn't figure it out). I finally loaded the drivers to get it to work USB with Mach3, but the x and z both move in the wrong direction in relation to which key is pressed.... and the spindle is not turning on.

Did you ever get yours worked out?

Offline FGS

*
  •  17 17
    • View Profile
Re: ABC's of YOOCNC 6040Z Setup
« Reply #14 on: May 30, 2018, 10:45:03 PM »
I've been trying to get my 6040 working since Feb. At first it seemed to be working cut the demo portion of the roadrunner. Then it failed. The Z axis would not cut into the material and it seemed like the movement was about 1/2 inch circle. I since dumped the Chinese controller and built my own control box using the best gear available. Gecko G540, Mean well 48V 12.5A PSU, 4 connector shielded cable. I was confident it was going to work. I've tried everything I can think of and I'm stumped. I'm able to jog the axis, although my X axis had to be reversed. 

Offline FGS

*
  •  17 17
    • View Profile
Re: ABC's of YOOCNC 6040Z Setup
« Reply #15 on: May 30, 2018, 10:47:45 PM »
Posted too soon. Meant to add, Does anyone have any ideas what it could be?
Re: ABC's of YOOCNC 6040Z Setup
« Reply #16 on: May 31, 2018, 03:07:31 AM »
Hi,
if you are using a Gecko 540 then you are using a parallel port...is this correct? What PC and OS are you using? Are you sure that the OS is 32 bit?

If so please run DriverTest,exe and post a screen shot of the result screen.

Craig
My wife left with my best friend...
     and I miss him!

Offline FGS

*
  •  17 17
    • View Profile
Re: ABC's of YOOCNC 6040Z Setup
« Reply #17 on: May 31, 2018, 10:20:12 AM »
Hi Craig, I'm using a UC100 to interface with the Gecko. I'm running W7 64 bit. That's supposed to work with the UC100. I have a Mean Well 48V 12.5A PSU. It's got to be something simple. I've tried so many different setups in Mach3 that I'm getting confused. I'm going to star over and see what happens. My motors are working fine. They're responding to my keyboard, although the X axis had to be reversed.
Thanks for the reply
Re: ABC's of YOOCNC 6040Z Setup
« Reply #18 on: May 31, 2018, 02:22:53 PM »
Hi,
so is the machine working or not?

Is Mach3 lincenced or not? In demo it will run for 500 lines before stopping.
Along the very top of the screen it should say 'Mach3 CNC ******************x'  where ****************** is the name of th licence.

Craig
My wife left with my best friend...
     and I miss him!

Offline FGS

*
  •  17 17
    • View Profile
Re: ABC's of YOOCNC 6040Z Setup
« Reply #19 on: May 31, 2018, 08:07:49 PM »
I'm running the demo. I did notice one thing this afternoon that doesn't seem right. While jogging the Z axis and watching the DRO they went from - to + in the middle of pressing page up. I'm pretty sure that's not right, but not sure how to change that. I don't have homing or limit switches and probably won't. I will set up soft limits after I get things running correctly.