Hello Guest it is December 10, 2019, 06:50:02 PM

Author Topic: Random wrong direction axis moves  (Read 5709 times)

0 Members and 1 Guest are viewing this topic.

Random wrong direction axis moves
« on: April 17, 2013, 09:42:18 PM »

I am getting random axis moves in the wrong direction.
It can occur on any axis and seems to happen at random times.
Usually everything works as it should but a couple times a day it will go the wrong way in the middle of a program that usually runs fine.
My setup is: Mach3, windows XP, CNC4PC C11 breakout board, automation technology drives

Thanks for any suggestions

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Random wrong direction axis moves
« Reply #1 on: April 17, 2013, 11:04:08 PM »
Might want to post a copy of your XML for HOOD to double check.

(;-) TP
Re: Random wrong direction axis moves
« Reply #2 on: April 18, 2013, 06:58:00 AM »
Is it when running a program, or your spindle is on? Maybe noise?
Re: Random wrong direction axis moves
« Reply #3 on: April 22, 2013, 10:38:51 AM »
Is it when running a program, or your spindle is on? Maybe noise?

It happens only when running a program and right after a tool change. Yes the spindle is running and is under mach3 control.  It happens with programs that usually run correctly.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Random wrong direction axis moves
« Reply #4 on: April 22, 2013, 11:16:49 AM »
Attach your xml and I will check your setup.
Hood
Re: Random wrong direction axis moves
« Reply #5 on: April 22, 2013, 06:17:09 PM »
Thank you Hood. Here is my XML file.
Re: Random wrong direction axis moves
« Reply #6 on: April 22, 2013, 09:40:44 PM »
At the risk of stepping on aconstruction's post.

I have a very similar problem.

Mach 3 while running a profile pass on a part has done two passes at different depths.

Then on the third pass which is exactly the same other than depth decides to change direction and cut into the part.

This always seems to happen on a radius.

I have attached my XML.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Random wrong direction axis moves
« Reply #7 on: April 23, 2013, 02:56:52 AM »
Ok, both aconstruction and CalJet can you tell me if, when the axis goes awry, the toolpath view shows it doing the correct motion and it is just the axis actually going wrong?

Hood
Re: Random wrong direction axis moves
« Reply #8 on: April 23, 2013, 03:57:26 AM »
Hood,

From memory (I usually hit the E stop to try and save the part) the tool path display shows what the tool is doing ie: it shows it going of course
not following the program.

Caljet

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Random wrong direction axis moves
« Reply #9 on: April 23, 2013, 02:13:31 PM »
Ok if it is going off track on the toolpath then Mach is telling it to do so, so it would be good to know for sure. If you can try and take notes of what exactly has happened when it does so and also be sure to check the toolpath  view it would be a great help in hopefully finding the issue.
Hood