Hello Guest it is April 18, 2024, 04:10:56 PM

Author Topic: G00 problem with mach3  (Read 5895 times)

0 Members and 1 Guest are viewing this topic.

G00 problem with mach3
« on: March 11, 2013, 04:55:58 AM »
I have a problem with G00 Command in Mach3 with DSPMC. For example i give G00 Z1, The Machine goes
0,62 and on the DRO i can see 0,62 - but i wanted to have 1 mm. Nevermind what Speed. This is
when I use G00. If i give G00 Z5 then machine goes to 4,62 mm. It seems that machine is about 0,1
seconds without PID loop and in this time Z travels down 0,38mm.

If I drive axis from DSPMC plugin gonfig it works fine.

If I reset Z counters from plugin control, VITAL DSPMC status Z drops every time 0,38mm.

I tried to push Y axis while giving g00X0, same happens to Y axis it will lose about 0,1mm
every g00.

It does not matter if I give G00X,Y or Z.

My config is:

DSPMC  7762S

Mach3 R3.043.066

DSPMC with latest firmware from vitalsystems website and mach3 plugin from same file.

Omron U-series servos with ballscrew from IA corporation.

Servos is analog input and speed mode.

Pulses 2000/revolution.
Re: G00 problem with mach3
« Reply #1 on: March 17, 2013, 11:43:05 AM »
Problem solved.

Problem was I max error.

So if I put something else than 0 to I max error machine works strange with G00 command.