Hello Guest it is October 23, 2020, 01:10:49 AM

Author Topic: MaxNC mode on gettoCNC  (Read 1775 times)

0 Members and 1 Guest are viewing this topic.

MaxNC mode on gettoCNC
« on: March 26, 2013, 11:17:06 AM »
Hi to all,

I'm Robert, forum reader from 3 weeks, green guy in CNC but motivated. Recently I lay my hands on 6 scanners. Scanner have steppers, cnc mills have steppers, so I add 2+2 and made my simple gettoCNC machine. I ripped off motors, rails and driver pcb's. Hooked up straight to driver chip (AMtek AMM56219) and all went well.

However chip is quadrature driver, not simple step/dir so I use MaxNC mode in mach3 (radiobutton "Max CL mode enabled"). So far so good. After axis calibration I noticed that on low feed rates motor looses few steps and not going so smooth. When axis calibration routine is going all is smooth and - not very scientific method - it sounds right. But on normal operation on jog something is wrong. I made 2 vids, one on normal move, and on on axis calibration routine, please ignore few back and forth moves at the end of first video.

normal move http://www.youtube.com/watch?v=uCYioJk9Q1I

calibration   http://www.youtube.com/watch?v=3ERmTMCraik

So my question, what is the difference betwen maxnc normal operation mode and axis calibration  ?  I try a lot feedrates but on anyone motors move so smooth as on calibration.Thx for help.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: MaxNC mode on gettoCNC
« Reply #1 on: March 26, 2013, 02:48:58 PM »
Run the driver test and see if you have a nice clean line.
Hood