Hello Guest it is July 23, 2019, 01:52:46 AM

Author Topic: Looking for help with setting Z axis downward travel limit  (Read 4518 times)

0 Members and 1 Guest are viewing this topic.

Looking for help with setting Z axis downward travel limit
« on: March 13, 2013, 08:01:21 PM »
I recently replaced the ball screw on the Z axis of my CNC router. The new one is about 2 inches longer than the original. Now my spindle can move downward to the point the bearing block will run off the rail.
I want to set Mach3 to prevent that. Any help is always appreciated.

Offline Chaoticone

*
  • *
  •  5,527 5,527
  • Precision Chaos
    • View Profile
Re: Looking for help with setting Z axis downward travel limit
« Reply #1 on: March 13, 2013, 08:21:57 PM »
Do you have a home switch on your Z axis?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Looking for help with setting Z axis downward travel limit
« Reply #2 on: March 13, 2013, 09:11:02 PM »
I don't think so Brett, although I'm a novice and it may be that I'm wrong.

Offline Chaoticone

*
  • *
  •  5,527 5,527
  • Precision Chaos
    • View Profile
Re: Looking for help with setting Z axis downward travel limit
« Reply #3 on: March 13, 2013, 09:18:57 PM »
You can set soft limits without home or limit switches, just better if you have a home switch because that is what the work off of.  Do you have a certain spot you always jog the z to when you refrence the machine?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Looking for help with setting Z axis downward travel limit
« Reply #4 on: March 14, 2013, 10:19:18 AM »
I do have a home switch on the z axis Brett. I set the position of z to various points depending on the piece I am cutting. I hit the Goto switch after each cut. What I am trying to prevent is operator error and what I want to do to set a limit that under any circumstance, won't allow the the spindle to travel down to the point where it will not allow the bit to damage the bed of the machine or for the spindle to travel downward to the point where the bearing block moves beyond the rail causing loss of bearings.

Offline Chaoticone

*
  • *
  •  5,527 5,527
  • Precision Chaos
    • View Profile
Re: Looking for help with setting Z axis downward travel limit
« Reply #5 on: March 14, 2013, 10:38:46 AM »
OK, you can set up softlimits either way but if your just jogging to a point and setting the MACHINE 0, softlimits sucess will depend entirely on the operator.  Home (refrence) your machine and jog the z down to where you want it to stop.  click on the machine coords. button and write down the value in the z dro.  Go to config., homing/limits and put that number in for your z min.  Set your slow zone big (several inches) at first to test with.  Go to the run screen and enable softlimits by clicking the softlimits button.  Should turn green around it then.  Test it slow by jogging the z down.  When it gets in the slow zone it will start slowing down and eventually stop at the machine coords you entered.  As always, test it slow and with caution and hand on estop...........  i dont want you hollering at me if you run z off the rails.  Eventually you can tune it to run as you want with a smaller slow zone etc. but for now just get it working and tested

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Looking for help with setting Z axis downward travel limit
« Reply #6 on: March 14, 2013, 10:54:03 AM »
Thanks Brett...I'll give it a go.
Re: Looking for help with setting Z axis downward travel limit
« Reply #7 on: March 16, 2013, 03:17:22 PM »
Hey Brett,

No luck so far. Before I started with your instructions, I took a photo (attached) of the screen and activated the soft limit switch. It stopped travel up to a limit and stopped but not down. When I tried to enter a z value I get a message saying Machine out of limits for soft limit activation.
I must be missing something and thought the photo might help in identifying my problem.

Offline Chaoticone

*
  • *
  •  5,527 5,527
  • Precision Chaos
    • View Profile
Re: Looking for help with setting Z axis downward travel limit
« Reply #8 on: March 16, 2013, 03:31:17 PM »
In that screen shot your machine has not been referenced so no telling where the machine z is at.  Disable your softlimits, reference the machine and then enable your soft limits and see if that works.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Looking for help with setting Z axis downward travel limit
« Reply #9 on: March 16, 2013, 03:42:46 PM »
I think where I'm losing you is referncing the machine...I don't understand what to do to accomplish that.

Bob