Hello Guest it is August 03, 2020, 06:06:02 AM

Author Topic: relay control headache  (Read 2321 times)

0 Members and 1 Guest are viewing this topic.

relay control headache
« on: February 23, 2013, 08:32:33 AM »
Hello folks,
I am new to Mach 3 again (- I dabbled with it last year). My breakout board is similar to this one:
http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=181075135780

I follow this advice:
http://www.buildlog.net/blog/2010/07/mach3-laser-cutter-setup/

I am trying to setup mach3 so I can switch the relay on/off using M3-M4 and M5 or E1Px.. and can't get it to work. I read everything I could around, but still don't get it. The mill works, with this pinout


X 2-14       (step pin =2 dir pin = 14)
Y 16-3
Z 7-8
A 6-5
B 4-17

whatever I do in the MDI (M3, M4 M5 with a small move after, or E1P1 E1P0)... nothing happens. The relay does not click (I also check with a continuity meter - no connection is made)

could anyone talk me through the setup? I know it's basic... but I can't get it to work!

many thanks

Thomas




Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: relay control headache
« Reply #1 on: February 23, 2013, 08:41:51 AM »
Those settings are all of your axis settings, they have nothings to do with controlling outputs (relays). You need to go the Outputs tab in Ports and Pins and tall Mach what Port/Pin your outputs are on. Then go the the spindle tab and make sure that things are set up correctly there.
Happy machining , Jeff Birt
 
Re: relay control headache
« Reply #2 on: February 23, 2013, 08:57:05 AM »
Thanks Jeff - I just wanted to show which pins I have available.

In Motor Output, I have Spindle disabled.
In Output Signals I have Output#1 activated, I set it to Port 1 and pin 9. How do I know which output my relay is connected to? Unfortunately I don't have the setup sheet for my breakout board anymore...
What setting do I need in the Spindle Setup?

At the moment in Relay Control I have
"Disable Spindle relays" is NOT checked
Clockwise (M3) linked to Output 1

In Motor Control
"Use Spindle Motor Output" is NOT checked

.. many thanks

Thomas
Re: relay control headache
« Reply #3 on: February 23, 2013, 09:06:15 AM »
Also, if everything was setup'd fine, would I be able to switch the realy on/off by using M3-M4-M5 or E1P1/E1P0 in the MDI?
If I type "X0.1" in the MDI the machine moves, but if I type any commands from M3-M4-M5 or E1P1/E1P0  I get a beep only...
Re: relay control headache
« Reply #4 on: February 26, 2013, 05:38:42 AM »
Finally found the problem...

I was looking at the relay contact with an ohmmeter - never got a signal. Then I had a look at the diode sitting across the relay contacts with a voltmeter - M3/M5 did indeed change the volatge across that!
It turns out that this breakout board is powered by a USB cable and did not get enough current to switch the relay on/off! With a better 5V power supply, things are working now...


cheers

Thomas

Offline Chaoticone

*
  • *
  •  5,628 5,628
  • Precision Chaos
    • View Profile
Re: relay control headache
« Reply #5 on: February 26, 2013, 09:47:17 AM »
 :)
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!