Hello Guest it is December 15, 2019, 07:22:24 PM

Author Topic: Printer driver installed in MaxNC mode motors run 1/4 speed  (Read 1629 times)

0 Members and 1 Guest are viewing this topic.

Offline BIW

*
  •  7 7
    • View Profile
Printer driver installed in MaxNC mode motors run 1/4 speed
« on: February 22, 2013, 11:46:28 AM »
I set up a PC with XP and a parallel port so I can get my THC to work.  I did a completely new install of Mach3 and included the printer driver.  In the port setup and axis selction screen, there is a box labled MaxNC mode.  THe max CL mode enabled is checked.  My X, Y and Z motor outputs tab shows that pins 2-3, 4-5, 6-7 on port 1 are enabled.  My motors however can only run off of 4-5 for Y, 6-7 for X and 8-9 for Z.  Also worth noting is that they run are 1/4 speed and I have a good idea on why that is after reading about MaxNC. 
Issue:
My situation however is that I need simple pulse and direction outputs from the parallel port on pins 2-3, 4-5, 6-7.  If I uncheck "Max CL mode enabled", the outputs from the printer port stop working. Jog keys and THC simulator switches still increment and decrement DROs but no output from parallel port -

Setup:
3 stepper motors sitting on bench connected to microstepping drivers.
Breakout board connected to parallel port.  Breakout board, drivers and motors are known good from running with a smoothstepper.
parallel port tests OK - and Speed is shown as excellent at 100Khz when tested.
If I run with MaxCL mode enabled everything works including THC which I simulated with switches works. but motors at exactly 1/4 speed and pin assigments in motor outputs tab appear to mean nothing.

Question is:
How do I get the parallel port working in simple pulse, direction mode

I would greatly appreciate some help on this - I'm about 12 hours into this problem now. I  have a completely fresh XP install and Mach3 is licensed.

Thanks

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Printer driver installed in MaxNC mode motors run 1/4 speed
« Reply #1 on: February 22, 2013, 12:38:41 PM »
UNcheck the box and then setup your machine in CONFIG ports/pins to match your machine.

In maxnc mode mach3 auto sets up the port/pins for a Maxnc machine.

Just a thought, (;-) TP

Offline BIW

*
  •  7 7
    • View Profile
Re: Printer driver installed in MaxNC mode motors run 1/4 speed
« Reply #2 on: February 22, 2013, 01:58:18 PM »
Did that several times already - tried it again after reading your post.  Still no ouput.  Even tried exiting and reloading Mach3 between every change.  Still no output to the port.  What is interesting to me is that I have two switches on some inputs and those work.  It is as though X, Y and Z are not getting mapped to the outputs.  I tried clearing them and then resetting them.  Then I removed everything from the PC including deleting the Mach3 directory.

This time I removed the parallel port cable at the computer's port then reinstalled Mach3 and parallel port driver.  It automatically installed it in Max NC mode.  Repeated all of the steps listed above and still no motor control.  I can turn each of the individual outputs on and off with pin mapping and a screen button so the parallel port is actually working fine.  My thought remains - it is as though the motors are not actually mapping to the outputs or that they are not really enabled.

Scratching my head on this one.

Offline BIW

*
  •  7 7
    • View Profile
Re: Printer driver installed in MaxNC mode motors run 1/4 speed
« Reply #3 on: February 22, 2013, 03:24:51 PM »
Figured it out, needed to reverse the output to active low. Direction and step had to be active low.