Hello Guest it is November 22, 2019, 07:51:06 AM

Author Topic: Mach3 machine material surface ZERO script  (Read 66468 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach3 machine material surface ZERO script
« Reply #10 on: April 11, 2013, 01:42:01 AM »
Hi All

My problem is still not fixed. I have installed the 2010 screenset which uses mm. Problem is still that mach3 is cutting air above the workpiece. The only problem i can see is that the plate thickness is not subtracted correctly so the mill can get to the workpiece.

I can get something to cut if i remove the plate and manually zero the mill to the workpiece. This works, but i would like to use the routine . Its difficult to see with the eye when the mill is just touching the workpiece.

THX
A
Re: Mach3 machine material surface ZERO script
« Reply #11 on: April 11, 2013, 04:14:16 AM »
Andre,

How are you running this code?  Is it button code attached to the set tool zero button?  I have found it very hard to make this work properly.  As an alternative, you could try the following.  Copy your code into Notepad; save it as a Mach3 macro, i.e. with the file extension .m1s, in the Macros folder in the Mach3 directory, making sure to avoid the macro numbers up to 100 that are used internally.  You could for example save it as M900.m1s which is the filename I used.  Now the button script you need to call this is just Code"M900".  I used this approach and it works just fine.

I'm not sure you need the "Exit sub" line at the end of your code - this doesn't seem to be a requirement for Cypress Basic.

And just a thought, trying to zero a tool onto a workpiece by eye is very hard as you have found out.  Much better is to slow jog onto a feeler gauge until it is just nipped between the tool and the material.  But probing is even better!

I've now got scripts on all the tool setting buttons that call probing macros in this way for setting tool height and also X and Y references, and they work fine.

John.
Re: Mach3 machine material surface ZERO script
« Reply #12 on: April 11, 2013, 05:19:32 AM »
Hi

I`m using the 2010 screenset. All macros supplied and in mm units. A have seen a lot of positive feedback on it, and it works fine and the moves are correct, but when it comes to the cutting part of the 1st depth increment, its above the workpiece.  I suppose in time as it get to the increments , it will eventually strike the workpiece, but not when it starts out.

This problem i never could get fixed. I had to cheat by eyeing the top ZERO on the workpiece. All the cuts i do, is done by eye Zeroing, but it would be nice for it just to work.
I bought the 2010 screenset to get away from editing the scripts , but it seemed that something else ...a setting in Mach3 maybe , is keeping me from getting it right.

My settings im Cambam is negative from ZERO , so -0.05 or -.5 , so it has to go down if + is up

UNLESS the problem lies when i ZERO the machine. My Zero setting is at the home position at the top end of the z-axis. I have been thinking bout this as well.
When i Zero the machine, Zero lies at the top (bout 100mm from the machine worktable). Does the auto zero option Zero the machine then back to the workpiece top , or does it just adjust the difference to work out workpiece Zero ?.

Thanx
A
Re: Mach3 machine material surface ZERO script
« Reply #13 on: April 11, 2013, 05:38:35 AM »
Andre, frankly I have learned to ignore the axes home setting!  As far as I am concerned, zero is what I set it to be.  My convention is that zero Z is the table surface; zero X and Y are (usually) the nearest left corner of the workpiece.  This way I know that any negative value of Z in the code will crash the tool into the table!  I use G-simple usually to generate G code, and this allows you to se the top surface of the "block" (i.e. material) at a known level above the machine table.  I set the tool tip to a known height by using a setting gauge, which is a spring-loaded plate that sits 38.84 mm above the table surface.  I position the tool just above this, hit the auto tool zero button, the tool moves slowly down, touches it, retracts slightly, retouches, then lifts up to Z=50 mm.

As I understand it, Mach 3 has a set of machine coordinates  which are related to the home position, in a way that you can configure.  On my mill (Denford Novamill) home is at minimum X but maximum Y and Z.  I have configured Mach3 with the corresponding maximum feed values for soft limit purposes, but actually I never ever refer to the machine coordinates, but zero the machine so that the X Y and Z DROs are, as I said above, relative to the workpiece and table surface respectively.
Re: Mach3 machine material surface ZERO script
« Reply #14 on: April 11, 2013, 06:41:31 AM »
I also have the fixed plate on the table, and the routine works fine when i run it. Till i find the culprit responsible for the aircuts, i `m gonna have to Zero the z-axis by manually.

Thanx
andre

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Mach3 machine material surface ZERO script
« Reply #15 on: April 12, 2013, 08:33:55 PM »
Try this.
Make sure that no g-code is loaded.
Place your plate on a sample workpiece, jog over it, and run the auto zero.

After it's finished, remove the plate.

Then, hit "Enter" to activate the MDI and type in G0 Z0, and hit enter again.
The tool should move down and touch the workpiece. If it does, then your zero is set correctly, and the problem probably lies with your g-code?

Note that with the 2010 screenset, there's an option to set zero to a location other than the surface of the workpiece. I call this the Material Offset. Make sure the Material Offset checkbox on the Toolchange tabis NOT checked.

Do the test above and let me know what happens.

If you still have trouble, send me your .xml file and some basic g-code that you're having trouble with. There are a LOT of 2010 screenset users, and none of them have ever had a problem with the auto zero macros.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Mach3 machine material surface ZERO script
« Reply #16 on: April 15, 2013, 01:32:11 AM »
Hi

I will run this test tonight and see what it does..

Thanx,
andre
Re: Mach3 machine material surface ZERO script
« Reply #17 on: April 16, 2013, 01:22:31 AM »
ok, so i have done the auto tool zero operation. all works fine and the operation completes flawlessly.

No Gcode is loaded yet.

When i type G0 Z0 the tooltip moves down to the workpiece , but keeps a 2mm distance from the stock. Its like the plate on top of the stock is still there.

What i have noticed is that when the auto tool zero completes and the tooltip pull away after the last slow auto tool Zero , the tip pulls away to clear the stock. This looks normal , and i can remember is a setting that is inside the macro that handles the tool zero operation.

All seem to be normal, but the tooltip is still (2mm)away from stock zero when i enter G0 Z0 into the DRO and hit enter.

Thanx
A

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Mach3 machine material surface ZERO script
« Reply #18 on: April 16, 2013, 08:29:37 AM »
On the toolchange tab, do you have any value in the Material Offset DRO, and is the box checked? Do you have the correct plate thickness entered in the DRO?

Can you send me your .xml file?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Mach3 machine material surface ZERO script
« Reply #19 on: April 17, 2013, 03:56:34 AM »
Hi All

Its sorted. I have re-checked the touchplate thickness. My touch plate setting thickness was set at 2.0mm , but the real thickness turned out to be 2.28mm. This made all the difference. :)


Thanx to everyone for suggestions and comments.

another happy chappy
andre