Hello Guest it is September 24, 2020, 05:04:50 AM

Author Topic: Cryptic Error Message....  (Read 1703 times)

0 Members and 1 Guest are viewing this topic.

Cryptic Error Message....
« on: January 30, 2013, 05:14:34 PM »
All of a sudden we're getting the following error message.....

Error on line: ********* ‐ Application defined or object defined error

Has anyone seen this?  It seems to be happening inside a macro that has a few While isMoving() statements.  It doesn't happen all the time.  Usually after the 3rd or 4th time the macro runs.  This is on a fresh install of Mach3 on a clean XP computer.  Wiped the HD, installed windows and installed Mach3.  We set this PC up to replace one that was randomly scaling parts for no reason.    My instinct tells me that this has to be PC related because we run the same code on many PC's.

Any ideas?

Thanks
Re: Cryptic Error Message....
« Reply #1 on: January 30, 2013, 10:36:47 PM »
Here's a little more info.  The error seems to be happening during a macro run that does a G31 Z-2.  It works 3 or 4 times, then fails.  When it fails, the probe trigger is ignored, the Z goes to -2 and stops.  Last time it did it, the next M code (M03) executed, but since the torch was bottomed out, it failed to light anyway.

I can execute this M code all day long in MDI and it will never fail.  It only fails during a program run.

I don't mind setting up another PC, but I'd like to know if this could be caused by something externally or if it is definitely a PC issue.

Thanks