Hello Guest it is June 17, 2021, 05:37:45 AM

Author Topic: Mach3 & Artcam ramping problems  (Read 12515 times)

0 Members and 1 Guest are viewing this topic.

Mach3 & Artcam ramping problems
« on: January 31, 2007, 11:02:38 AM »
Has any body got any thoughts on this one...we are looking at using artcam insignia with mach3, The guy from artcam has been over and sorted out the post processor to work with mach3 (forgive me if nothing makes sense from now on as i really havent got a clue whats going on) when the machine goes to cut a simple slot the cutter ramps down into the cut even though all ramping has been switched off, the g code isnt telling it to ramp down, the displays shows that the tool path doesnt ramp down but it still does - well it had both of us scratching our heads !!! ??? ???

Offline GaryB

*
  •  108 108
    • View Profile
Re: Mach3 & Artcam ramping problems
« Reply #1 on: January 31, 2007, 11:12:41 AM »
Post the start of your code where this happens but it sounds like your machine is starting to move in x or y direction before the z has reached the correct depth. The post processor may need re-adjusting.
Is the z move listed in the g-code before or after the x y moves?
Beckwith Decor Products
ArtCam Trainer
Onsrud & Custom CNC tooling Distributor

Wichita/Derby Kansas
http://www.beckwithdecor.com

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: Mach3 & Artcam ramping problems
« Reply #2 on: January 31, 2007, 11:28:52 AM »
One other thing, how is your material set up in artcam? I have sent you a pm.


Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Mach3 & Artcam ramping problems
« Reply #3 on: January 31, 2007, 11:53:47 AM »
I will get that lot posted but ive just had a word with the artcam guy who showed me the live simulation of the toolpath's being cut and everything is how it should be, i.e. travels along, stops, goes down, stops and cuts the slot then comes back out with no ramping....Ill get the g code up here if i can

Cheers

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: Mach3 & Artcam ramping problems
« Reply #4 on: January 31, 2007, 12:03:57 PM »
In config, safe Z setup. Do you have allow safe z moves checked?


Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Mach3 & Artcam ramping problems
« Reply #5 on: January 31, 2007, 12:43:52 PM »
Here is the G code

N0 G21
N10 G40 G90
N20 F1
N30 M6 T1
N40 G43 H1
N50 M04 S0
N60 G00X0.0Y0.0
N70 G00 Z10.0
N80 G0X27.5Y207.2Z2.0
N90 G1Z-5.0F600.0
N100 G1X27.5Y207.3Z-5.0F600.0
N110 Y209.3
N120 X27.4Y209.3
N130 Y207.3
N140 G0Z2.0
N150 G0X0.0Y0.0Z10.0
N160 G00X0.0Y0.0
N170 M05
N180 G49
N190 M05 M30


I Just looked in config and i cant find anything about safe Z setup ( told you i dont have a clue ) ??? ???

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: Mach3 & Artcam ramping problems
« Reply #6 on: January 31, 2007, 12:55:16 PM »
You do have rapid move in that code. The G0s are rapid comands. Did you get the personal message I sent you?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline GaryB

*
  •  108 108
    • View Profile
Re: Mach3 & Artcam ramping problems
« Reply #7 on: January 31, 2007, 01:18:25 PM »
Think Brett is correct you have not set your material up correctly. Looks like you have a top offset of 10mm in artcam, assuming line 80 is the ramp move that cuts into your material & you are zeroed to material surface
« Last Edit: January 31, 2007, 01:21:38 PM by GaryB »
Beckwith Decor Products
ArtCam Trainer
Onsrud & Custom CNC tooling Distributor

Wichita/Derby Kansas
http://www.beckwithdecor.com

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: Mach3 & Artcam ramping problems
« Reply #8 on: January 31, 2007, 01:59:00 PM »
I don't think this has anything to do with your problem but here is a screen shot to help.


Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: Mach3 & Artcam ramping problems
« Reply #9 on: January 31, 2007, 02:02:17 PM »
I think this is where your problem is.


Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!