Hello Guest it is July 18, 2019, 07:51:05 AM

Author Topic: Changing computers  (Read 7732 times)

0 Members and 1 Guest are viewing this topic.

Re: Changing computers
« Reply #30 on: January 23, 2013, 10:40:31 AM »
OK Hood and Angel-Tec, explain this! I bought my secondhand computer off the internet, not that I'm tight but didn't want the hassle of 64 bit (well I am a bit tight when it comes to money). The computer came with loads of programs on it and it had obviously been linked to other computers in an office or school.
I was confused because this creep problem only started when I connected the new computer to my machine. I accidental left the power to my machine on from the last time I was messing with it, so it was still on when I pressed the on button to start the computer. As I pressed the button the spindle started even before I had called Mach3.
That got me thinking is there a signal going down the printer port? As I mentioned there were loads of programs on the hard drive so decided to dump them all as the computer was only going to run Mach3. I dumped AVG software, Kodak printer and photo suite, loads of little files like spybot whatever that is, plus countless interface files. Well touch wood been using the CNC milling for the past hour and the creeping spindle has gone. Could it have been one of the software programs I have deleted that was sending a signal down the parallel printer port connection? That 2.2v signal has disappeared and the spindle has started maintain a constant speed I requested (got a digital rev counter to check the spindle speed). Don't want to speak to soon but I may have solved it, keep you posted. If I have I'm going to write to those guys controlling the Mars Lunar Landing Vehicle and see if they want any help drilling those holes in the Mars landscape.
Hood and Angel-Tec would welcome your thoughts as to if this could have been the problem or was it the fact that I waved a sledge hammer at the spindle earlier in the day. Jim
Re: Changing computers
« Reply #31 on: January 23, 2013, 11:04:46 AM »
Yes the parallel port's outputs are switched on when windows starts, breakout boards stop this by having a charge pump.

I ALWAYS DELETE THE PARTITION AND REFORMAT THE HARD DRIVE AND ONLY INSTALL WINDOWS XP AND MACH3 ON THE COMPUTER, but be carefull not to delete the small partition on the drive as it's needed on dell machines to boot the drive.

It's quite possible that another program had access to the parallel port and was affecting it.

If you raise the low limit of the spindle pulley to 100 you will see if the enable is working.

Online Tweakie.CNC

*
  • *
  •  7,845 7,845
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Changing computers
« Reply #32 on: January 23, 2013, 11:11:49 AM »
Jim,

I vaguely remember something that came up years ago where a PC, that had been previously used with a printer (connected to the parallel port) still had a document waiting in the print queue.

Windows, bless it’s little heart, chose every quiet moment to try and communicate with the now non-existent printer thus causing problems with the logic state of some of the parallel port output pins.

Just maybe, perhaps ?

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Changing computers
« Reply #33 on: January 23, 2013, 11:15:30 AM »
the parallel port has been used for controlling machines for donkeys years, mach3 is not the first add on to use it. So yes funny things can happen, and tweakie i can see that happening.