Hello Guest it is November 12, 2019, 11:50:39 PM

Author Topic: Inputs Not Working in Windows 7 32-bit  (Read 2044 times)

0 Members and 1 Guest are viewing this topic.

Inputs Not Working in Windows 7 32-bit
« on: December 04, 2012, 04:03:08 AM »
Seeing as this is my first post I hope you don't mind if I start of with a question.
I can't seem to get my Homing/Limits to work. I have tried almost everything.
The only way I can get them to work is if I disconnect my Breakout Board, but once I connect my breakout board the switch leds turn on as if they were triggered. I have tried running the Parallel port in EPP-1.9 and SPP, EPP-1.7 and SPP and Printer Modes but neither of them seem to help. Under Device Manager I told the Parallel port to accept all interrupts. This didn't help. Basically it seems like somewhere in the breakout board my input pins are grounding and theoretically being switched.
What am I doing wrong?
I'm using the following components:
Internal LPT1 Parallel port
Windows 7 32bit
This breakout board:
http://buildyourcnc.com/images/breakoutv1wiring.pdf
Please help me fix this very tricky problem I'm having. thanks for helping out, and if you need any more info let me know.