Hello Guest it is December 10, 2019, 12:20:09 AM

Author Topic: Pokey 56U with two mpg  (Read 4106 times)

0 Members and 1 Guest are viewing this topic.

Pokey 56U with two mpg
« on: November 29, 2012, 12:49:34 PM »
I have rebuild a Lathe to Mach3, the stepper drives of the machine are controlled through a parallel port interface.
The machine has also a pokey 56u and a kdb48CBC keyboard. The machine has also two encoder which I want to use as mpg for
the x and the z aches. The encoders are connected to pin 18,19 and 20,21 (so encoder 4 and 5).
Pokeys config software and mach3 plugin from 25-11-2012 is installed.
In the plugin settings the encoder 4 is connected to DRO 101 and encoder 5 to DRO 103.
The values in the DRO 101 is correctly responding to the first encoder MPG 1 (x) and DRO 103 to the second MPG encoder (z).

The problem now is that when the X is selected on the keyboard (MPG jogging) then the X axis is responding on the first encoder (MPG) but the
X axis is still moving also when the encoder (MPG) is not changing its value. When I press stop (end jogging) then the axis stops but when I restart jogging
the X axis starts moving.
What I notice is that the value in DRO 101 is switching between 0 and the encoder value every few seconds, so it seems that something else is also
writing to the same DRO 101 !
Is this the reason that the X axis is constantly moving ?

Am I doing something wrong ? Or have is missed a setting somewhere ?

Thanks in advance.

Offline NeoTO

*
  •  504 504
    • View Profile
    • PoLabs
Re: Pokey 56U with two mpg
« Reply #1 on: November 29, 2012, 01:55:49 PM »
Do you have any other plugin activated? Also, have you configured Mach3 to use LPT port for MPGs?
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope
Re: Pokey 56U with two mpg
« Reply #2 on: November 29, 2012, 02:21:57 PM »
Only the pokeys plugin is activated (together with the standard activated plugins, with installation).

What do you mean with "have you configured Mach3 to use LPT port for MPGs".
In the ports and pins section (tab encoder/mpg), the MPG are not enabled.

Offline NeoTO

*
  •  504 504
    • View Profile
    • PoLabs
Re: Pokey 56U with two mpg
« Reply #3 on: December 03, 2012, 01:38:14 AM »
the MPG must be enabled in Port and Pins (plugin should automatically enable it for you), but should not be configured with Port and Pins fields.
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope
Re: Pokey 56U with two mpg
« Reply #4 on: December 04, 2012, 08:11:40 AM »
I have found the problem.
On the machine there has been a connection with a modbus card in the past. This was not connected any more but
still selected in the software. So in the modbus settings MPG1 was enabled
After removing the modbus settings, the MPG`s are working as they should.
Just need to find the settings so they ate responding smothely.
Thnak you for your help.