Hello Guest it is July 11, 2020, 05:50:20 PM

Author Topic: Mach 3 with Xylotex Control  (Read 7117 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 with Xylotex Control
« on: January 27, 2007, 12:30:10 PM »
 I am having difficulty in getting Mach 3  to  work  with my Xylotex Control.   When I power up  my  control the steppers will lock  but i  cannot get them to  move  by inputting any commands from mach 3.   I have  setup Mach 3  with the same port  and pin settings that I use in mach 2.    Is anyone using mach3   with the  Xylotex 4 axis control  using stepper motors? If you are could you email me your XML setup file so I can check it against mine? 

 If you have any suggestions please post them as well.

 Thanks in advance!

Scott

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: Mach 3 with Xylotex Control
« Reply #1 on: January 27, 2007, 03:32:39 PM »
Hi, Scott

In config, Ports & Pins, Motor Outputs, change the State of Dir LowActive and Step Low Active from X to Check or Check to X, change by

clicking on them.

Also make sure the Step & Dir Ports are set to 1.

Don't forget to click on Apply

Hope this helps, Chip

Offline rcrabb

*
  •  146 146
    • View Profile
Re: Mach 3 with Xylotex Control
« Reply #2 on: January 27, 2007, 04:13:55 PM »
I have the 4 axis Xylotex board. As chip said Check your ports and pins. If your still having problems, post your XML file so we can take a look.
Ryan

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Mach 3 with Xylotex Control
« Reply #3 on: January 27, 2007, 08:14:05 PM »
Scott,
    Have you changed the e-stop in ports and pins, inputs to active low or high and tried it?


Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Mach 3 with Xylotex Control
« Reply #4 on: January 27, 2007, 09:03:51 PM »
Ok here is what I have.   After numerous attempts trying to get mach 3   to move my steppers I decided to try  a different computer.  I took  my desktop  to the machine , Installed the Mach 3 software, set  the configuration to the same settings I was trying to run on the  previous computer and guess what  IT  WORKS!!!  So  the problem is within the computer itself.   The computer  that  I was trying  to get Mach 3 to run on  was a pentium 3 machine running windows XP  and has 512 MB ram.    I am not  sure what to look for in the  computer but at least I now know where the problem is.

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Mach 3 with Xylotex Control
« Reply #5 on: January 27, 2007, 09:14:04 PM »
Scott, does the first computer have a wireless network connection?


Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Mach 3 with Xylotex Control
« Reply #6 on: January 27, 2007, 09:44:54 PM »
Brett,

 No wireless connection on the first computer.

Scott

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Mach 3 with Xylotex Control
« Reply #7 on: January 27, 2007, 09:48:54 PM »
What is your processor speed?

I have sent you a personal message.

Brett

;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Mach 3 with Xylotex Control
« Reply #8 on: January 27, 2007, 10:57:30 PM »
The computer in question  has a AMD Athlon  Prosessor running 1.49 GHZ.    This system only has 256 MB RAM.  Could this be my problem?

Scott

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Mach 3 with Xylotex Control
« Reply #9 on: January 28, 2007, 06:27:46 AM »
Hi Scott,
    I'm not 100% certain but I think it may be. Do a search on PC minimum requirements in this forum. Get some solid answers to this question before you buy anything.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!