Hello Guest it is May 19, 2019, 11:38:26 PM

Author Topic: Is this pin configuration correct?  (Read 2534 times)

0 Members and 1 Guest are viewing this topic.

Is this pin configuration correct?
« on: February 07, 2006, 03:47:15 AM »
I'm building my dream machine.  I'm fairly new, so I need some help making sure my pin configuration is correct.

Inputs                     Port        Pin
Index Pulse            1    10
E Stop                      1     11
X Home                    1   12
Y Home                    1   13
Z Home                    1   15
Encoder A X axis   2   2
Encoder B X axis   2   3
Encoder A Y axis   2   4
Encoder B Y axis   2   5
Encoder A Z axis   2   6
Encoder B Z axis   2   7
MPG A X axis            2   8
MPG B X axis            2   9
MPG A Y axis            2   10
MPG B Y axis            2   11
MPG A Z axis            2   12
MPG B Z axis            2   13
                          2   15

Outputs                    Port   Pin
Spindle Step            1   1
Spindle Direction   1   2
Coolant Relay            1   3
X Axis Step            1   4
Y Axis Step            1   5
Z Axis Step            1   6
X Axis Direction   1   7
Y Axis Direction   1   8
Z Axis Direction   1   9
A Axis Step           1   14
A Axis Direction   1    16
                           1   17
                              2   1
                           2   14
                           2   16
                           2   17
Re: Is this pin configuration correct?
« Reply #1 on: February 07, 2006, 05:26:50 AM »
I can see a few that could be a problem. You have pin 8 port 2 as an input... This can be done but you have to have Mach set to use them (check box on the ports and pins )

Other t than that it looks Okay
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com