Hello Guest it is September 21, 2019, 02:05:36 PM

Author Topic: Plasma Consumable Tracking  (Read 26016 times)

0 Members and 1 Guest are viewing this topic.

Re: Plasma Consumable Tracking
« Reply #70 on: November 01, 2012, 05:52:45 PM »
I've been messing with the Stackumup macro on and off all day. Even this version I messed with works perfectly from the editor. But when run from the button it drops the Cdown to 0 and only makes 1 part.

'Macro M3007 Auto Batch Load Horizonal
Dim fname As String
Dim Cuts As Single
Dim Xext As Double
Dim Yext As Double
Dim Test As String
Dim Cdown As Single

Sub Main()

Test = ("No File Loaded.")
Fname = FileName()
While Ismoving()
Wend
Message"" &Fname
While Ismoving()
Wend
If Fname = Test Then
 MsgBox("No File Loaded, PLEASE LOAD FILE and RESTART")
 End
End If
Cuts = Question("How Many Horizonal Parts UP TO 10 ?")
If Cuts >10 Or  Cuts <1 Then
 MsgBox(" Number Out Of Range 1-10 Retry Again ")
 End
End If
Cdown = Cuts
SetUserDro(2010,Cdown)

N1:

RunFile()
While Ismoving()
Wend
Message" Parts to Go: "& Cdown
Xext= GetOemDro(10)
While Ismoving()
Wend
Yext= GetOemDro(5)
While Ismoving()
Wend
Code" G0 Z1.00"
While IsMoving()
Wend
Code"X" & (Xext + .250)
While Ismoving()
Wend
Code"Y"& Yext
While IsMoving()
Wend
DoButton(9)
While Ismoving()
Wend
DoButton(8)
While Ismoving()
Wend
Cdown=(Cdown-1)
If Cdown >= 1 Then
 SetUserDro(2010,Cdown)
 While Ismoving()
 Wend
 GoTo N1
ElseIf Cdown=0 Then
 Message("End Of Batch Load")
 End
End If
End Sub

What do you make of that?
Auto scale looks really nice. Play time. LOL

GL
« Last Edit: November 01, 2012, 05:54:34 PM by scbrniddvl »

Offline BR549

*
  •  6,898 6,898
    • View Profile
Re: Plasma Consumable Tracking
« Reply #71 on: November 01, 2012, 05:59:09 PM »
Yep that IS the main problem. I cannot find a way to keep the VB side in Sync with teh Gcode side in all cases. It all works here EVERY time from a button or the editor BUT I know what it does on other machines. It blows right by all the Gcode  stuff in one pass and does the last run.

I am truing to work out a solution even IF it is long winded to make it behave. ALL help welcome.

COme right up and take a shot at the autostackumup function. Earn your wizard badge in one session(;-)  Makes us look like dummies we don't care we are tuff. (;-)

(;-) TP
Re: Plasma Consumable Tracking
« Reply #72 on: November 01, 2012, 06:07:51 PM »
LOL. What computer are you using? What Kernal speed due you run in Mach?
With one confuration I did, I got a "Cannot Zero while running" Error. Don't know what was up with that.

Wondering?

GL
« Last Edit: November 01, 2012, 06:24:34 PM by scbrniddvl »

Offline BR549

*
  •  6,898 6,898
    • View Profile
Re: Plasma Consumable Tracking
« Reply #73 on: November 01, 2012, 06:30:33 PM »
You got the error because mach3 was till RUNNING the Gcode program at the same time it was trying to Rezero the axis. The CB code was jumping over the Gcode and running at the same time.

Try this version(;-) AND yes it runs file here. But that is not unusal.   

(;-) TP
Re: Plasma Consumable Tracking
« Reply #74 on: November 01, 2012, 06:48:27 PM »
Unfortunately, nope. Maybe rather than run it normally, can you have run from the editor? lol I know I'm a wise ass.

Got to go eat dinner

Thanks

GL

Offline BR549

*
  •  6,898 6,898
    • View Profile
Re: Plasma Consumable Tracking
« Reply #75 on: November 01, 2012, 07:13:58 PM »
NOPE it runs from a button on the main screen (;-) Running it from the editor is easy almost anything will run OK from the editor. 

Perhaps some others can test the code to see IF it runs from their machine(;-). I can't have the only 2 computer that can run this OR can I ?

(;-) TP

Re: Plasma Consumable Tracking
« Reply #76 on: November 01, 2012, 07:23:46 PM »
Oh well it will get figured out sooner or later. lol

GL
Re: Plasma Consumable Tracking
« Reply #77 on: November 01, 2012, 09:23:57 PM »
Ok, Terry. You have to level with me. What computers do you have. What's you General config settings in Mach and on which foot do you stand when you push the botton. lol


 ???

GL

Offline BR549

*
  •  6,898 6,898
    • View Profile
Re: Plasma Consumable Tracking
« Reply #78 on: November 01, 2012, 09:36:26 PM »
V.066 Acer Puter Vista of all things and it works fine here and at the shop on 2 different dells running XP and .043.020.

Now the version at the shop is slightly different but that was the very first version that you tried AND it did fail here there same way you have had it do . BUT the MODs I did from there on out work fine here before I posted them.

Looking BACK at some old trouble notes this has ALWAYS been a problem so It limits what I can send out for yall to use.

(;-(   Well what would YOU like to create that would help you out?

(;-) TP

« Last Edit: November 01, 2012, 09:40:35 PM by BR549 »

Offline BR549

*
  •  6,898 6,898
    • View Profile
Re: Plasma Consumable Tracking
« Reply #79 on: November 01, 2012, 09:42:52 PM »
NOW just a thought are you running simulation mode without the driver loaded???  Here I am running WITH the driver loaded.

Just a thought, (;-) TP