Hello Guest it is July 12, 2020, 04:17:58 PM

Author Topic: DRO's change but motors do not move, until Mach3 is restarted  (Read 11871 times)

0 Members and 1 Guest are viewing this topic.

Offline DMBGO

*
  •  200 200
  • Time is the same in a relative way
    • View Profile
Re: DRO's change but motors do not move, until Mach3 is restarted
« Reply #20 on: October 19, 2012, 08:24:37 AM »
I don't think I wrote a custom macro, but maybe I did at some stage. It happens with a clean install, so I am dubious, that I wouldn't have noticed it b4. Perhaps mach3 has changed? It is possible that option wasn't enabled by default in previous versions?
Cheers

David

Offline DMBGO

*
  •  200 200
  • Time is the same in a relative way
    • View Profile
Re: DRO's change but motors do not move, until Mach3 is restarted
« Reply #21 on: October 19, 2012, 08:26:21 AM »
I will duplicate the issue tomorrow and see if a reset fixes it.

Cheers

Dave
Cheers

David

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: DRO's change but motors do not move, until Mach3 is restarted
« Reply #22 on: October 19, 2012, 08:30:41 AM »
I think you are misunderstanding what I am meaning about the macro. It has nothing to do with your problem at all, I had just asked what was in that macro as it is in your init string and originally thought it may have had something to do with it.
 You said what was in it and basically all it was doing was setting the spindle speed DRO to 1000. It is a custom macro as there is not a standard Mach macro with that number. So all I was saying was having s1000 in the init string would have done the same thing and there would have been no need to write a custom macro for it.
Hood

Offline DMBGO

*
  •  200 200
  • Time is the same in a relative way
    • View Profile
Re: DRO's change but motors do not move, until Mach3 is restarted
« Reply #23 on: October 19, 2012, 04:23:46 PM »
Sorry Hood, my mistake, I thought you meant that about the macro. I meant that I will install a lower version of mach today and see if the same option that was causing my issue is checked. If the problem still exists, I will try a reset. I don't normally press reset, since my understanding is that you then need to rehomee axis etc, to make sure they are in the same place.
Cheers

David

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: DRO's change but motors do not move, until Mach3 is restarted
« Reply #24 on: October 19, 2012, 04:31:58 PM »
Yes you really do need to rehome after you press reset, well if it disables your drives anyway. Steppers will move to the nearest full step when disabled and servos may move depending on tension etc.
Hood

Offline DMBGO

*
  •  200 200
  • Time is the same in a relative way
    • View Profile
Re: DRO's change but motors do not move, until Mach3 is restarted
« Reply #25 on: October 20, 2012, 06:15:42 PM »
A reset works for me too I didn't try this b4, because as you rightly confirm, the position would be lost. Also I think I said that the "On program end tun off all outputs" box was checked by default, but I now think I was wrong. A clean install leaves this unchecked. This explains why I didn't come across this issue b4.
Cheers

David

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: DRO's change but motors do not move, until Mach3 is restarted
« Reply #26 on: October 20, 2012, 07:02:55 PM »
I had never seen it before either but I never had that option chosen as I dont want to disable my servos unless I choose to do so.
Hood

Offline DMBGO

*
  •  200 200
  • Time is the same in a relative way
    • View Profile
Re: DRO's change but motors do not move, until Mach3 is restarted
« Reply #27 on: October 21, 2012, 12:47:33 AM »
I'm with you, but I didn't realise I had chosen it.....
Cheers

David