Hello Guest it is October 21, 2020, 12:16:38 AM

Author Topic: Help with Stepper Driver  (Read 3556 times)

0 Members and 1 Guest are viewing this topic.

Help with Stepper Driver
« on: November 19, 2012, 11:26:25 AM »
Hi everyone.
  I'm putting together my first CNC machine (router) and am looking for help getting my stepper motor drivers running.  I know this site is mostly about the mach3 sofwtare, but I am hoping some one will recognize this problem and help me get going.  Here is what I have:

X-axis= CW8060 driver (rated 6A), 5A stepper motor, 4 lead

Y-axis = CW230 driver (rated 3A), 2.7A stepper motor, 8 lead, wired in parallel
Z-axis = CW230 driver (rated 3A), 2.7A stepper motor, 8 lead, wired in parallel

BOB = unknown manufacturer, "rev5" from buildyourowncnc.com

I have the x-axis motor/driver running properly, but I can't get the y or z axis to move.  What I have tried:
 1- Moved the motor leads (at the driver) from the y-driver to the x-driver.  The CW8060 driver will spin the smaller motors, so motors and connections must be OK
 2- Moved the x-axis output from the BOB to the inputs on the y-axis driver - no movement
 3- Confirmed via oscilloscope that the BOB is sending the same pulses to x-driver and y-driver
 4- Replaced complete y-axis driver with new out of box- same no movement of Y or Z motor
 5 - If I look at the x-axis motor leads on a scope, I see a 36V pulse when the motor is moving and nothing when the motor is idle.
 6- If I look at the y-axis motor leads on a scope, I see a 72V (or +/-36V) pulse at all times (trying to move the motor or not)
 7- Tried swapping CP and CW inputs on the y-axis drive with no success.

Thanks for any help you can provide
Re: Help with Stepper Driver
« Reply #1 on: November 28, 2012, 11:01:21 PM »
   Well I got it figured out.  For the CW230 drivers I needed to set up the software for active low step drivers, but the bigger driver on the X-axis was OK with active high driver output.  Now I have all 3 axis running.