Hello Guest it is December 06, 2019, 07:48:01 AM

Author Topic: Reset  (Read 3225 times)

0 Members and 1 Guest are viewing this topic.

Offline Kym A

*
  •  13 13
    • View Profile
Reset
« on: September 10, 2012, 07:33:37 PM »

Hello Forum

Thought you may have an answer on this one.

I have my HF spindle running and controlled via a VFD by Mach3.

When I first start a machining run the spindle fires up as it should and shuts down at the end of the machining as it should.

Now if I want to repeat the machining e.g. doing a multiple run of the same design the spindle will not start up when the command is given to start the run.

It will only start as it should if I press the reset and reset before starting.

It’s not a big problem, I was just wondering if this is normal procedure?

Cheers,
Kym

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Reset
« Reply #1 on: September 11, 2012, 02:53:10 AM »
Its not normal and not sure what could cause it but if you attach your xml  I will see if there is a config problem.
Hood

Offline Kym A

*
  •  13 13
    • View Profile
Re: Reset
« Reply #2 on: September 11, 2012, 04:33:27 AM »
Hello Hood,

Do you mean you want to see the Mach 3 input and output configuration?
Kym

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Reset
« Reply #3 on: September 11, 2012, 04:53:30 AM »
The xml is a file that contains your config, it  is in the main Mach3 folder. The name of it will depend on the name of the profile you are using so if you open Mach as normal and look lower right at the profile name you can then look for a file with that name and a xml file extension. You will likely need to rename for the forum to accept so right click it and copy then go to your desktop and right click a blank spot and choose paste, you can then right click it and rename, maybe Kym_A.xml would be a suitable name. You can then use the additional options button on the reply page to browse to the renamed file and attach it to the forum.
Hood

Offline Kym A

*
  •  13 13
    • View Profile
Re: Reset
« Reply #4 on: September 11, 2012, 06:38:53 AM »

Hello Hood,

Thank you for the guide....hopfully the file is what you have requested....Kym A XML
Kym

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Reset
« Reply #5 on: September 11, 2012, 07:07:18 AM »
Seems to be fine here, in simulation at least. When the spindle doesnt start on the second round do you see the spindle LED flashing on the main page? Do you see any error messages in the ticker line at the lower left of the main page?
Hood

Offline Kym A

*
  •  13 13
    • View Profile
Re: Reset
« Reply #6 on: September 11, 2012, 07:48:41 AM »

The spindle LED does not flash...not sure about the error message will check that out in the morning.
Kym

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Reset
« Reply #7 on: September 11, 2012, 08:04:44 AM »
Ok well at least thats something, could be your macro is the problem but you will get a message if it is.
Hood

Offline Kym A

*
  •  13 13
    • View Profile
Re: Reset
« Reply #8 on: September 11, 2012, 06:55:31 PM »

Is it the status bar that the message should be in?...if so no there is no error message.
Kym

Offline Kym A

*
  •  13 13
    • View Profile
Re: Reset
« Reply #9 on: September 11, 2012, 09:19:42 PM »
Hello Hood,

I have created a new Profile and that seems to have solved the problem.

Have attached the XML if you wish to compare.
Kym