Hello Guest it is November 26, 2022, 03:31:44 PM

Author Topic: Z Axis Stops Working / Fails To Move  (Read 5116 times)

0 Members and 1 Guest are viewing this topic.

Z Axis Stops Working / Fails To Move
« on: August 06, 2012, 07:00:16 AM »
Hi All,

I'm new to CNC'ing and Mach3 but over the last couple of months have slowly been working through the issues with my Taig2000 micro mill setup with a Microproto controller which I recently purchased second hand.

After many, many hours of setting up and debugging the setup I thought I had it sussed but I now have one final issue to resolve.

I was machining a part over the weekend and all was looking good until disaster happened. At end of a profile run the Z axis didn't physically move back its safe height even though the DRO on Mach3 showed that it did. The motor itself didn't make any noise so it wasn't stalled as I had when configuring the machine initially (I know that noise well), it just didn't move. The consequence of this was a nice machined groove across the surface of my part and then the Z axis tried to plunge the bit back through the work piece due to it being out of position relative to the DRO.

I think I may have caught a situation a little like this before where when jogging around the Z axis fails to respond. If I then move either the X or Y axis and go back to the Z axis it then moves normally (I have never looked to see if the DRO is still moving in this situation). I am using the Joypad plugin with a Logitec Joypad to jog and I had wondered if this could cause have caused this issue but not sure if would have any affect when running a program.

I have Mach3 R3.043.022 installed and I'm now running on a 3GHz P4 dedicated PC with a PCI parallel card and all the suggested windows XP optimizations in place after a lot of trial and error to begin with.

Anyone have any suggestions?  ???


Re: Z Axis Stops Working / Fails To Move
« Reply #1 on: August 06, 2012, 07:29:24 AM »
Double check all of your terminal connections and wiring.
Sounds like you might be dropping the pulse signals between Mach and your motor drives.
Might be that simple.

Re: Z Axis Stops Working / Fails To Move
« Reply #2 on: August 13, 2012, 09:18:45 AM »
Thanks Overloaded. Checked through all the wiring and connections and all looks good so don't think its the root cause of the issue I'm seeing here. I ran the program again over the weekend and the same thing happened (at a different point in the program) with the G0 Z3.0 return to safe Z command. It's a large 2.5D file with 450,000 lines so I can't really sit there and watch it continuously but I did catch what I think was the motor stalling when moving the Z and hence had to reset the Z height. By the time this had happend I was already through 20,000 lines of code so its definitly not a regular occurance and struggle to understand how it could be a motor tuning issue.

Any ideas?  ::)
Re: Z Axis Stops Working / Fails To Move
« Reply #3 on: August 13, 2012, 10:47:53 AM »
One more .... could be related to your power supply.
Could be stalling during a combined axis G0 move.
Is there any excessive heat ? Motor or Z driver ?
Axis all lubed up well ?
Re: Z Axis Stops Working / Fails To Move
« Reply #4 on: August 13, 2012, 11:13:23 AM »
You can also program a long relatively slow z axis move, then while it's running wiggle all wires and connectors to see if you can create and interruption.
A break between a stepper drive and motor can and likely will damage the drive.  (so I"ve heard, never did it to see)
Re: Z Axis Stops Working / Fails To Move
« Reply #5 on: August 24, 2012, 05:13:15 PM »
Yep, I've experienced this problem myself.  I ran onto this one trying to fix my own random motor stall problem.  I figure an overload condition induced a motor stall in the 'x' axis while all 3 axes were 'going-at-it' so to speak.  I think Russ could be right... 'the power supply could be stalling during a combined axis G0 move due to excessive heat.